How to add can-utils to wp7608 linux image

Hi,

I am using Release R13.1 for wp7608. I want to add can-utils in the linux image. How should I download linux source and make the necessary changes? I am new to building custom yocto images, detailed steps would be appreciated.

I followed following links:

https://docs.legato.io/latest/toolsGitHub.html

I am able to run the repo init command succesfully:

Please can someone guide me with the next steps?
@jyijyi
@ajoseph

Regards,
Devanshu Agarwal

Then can you download the linux source code?

@jyijyi I am ble to see following folder after running repo init command:

Which folder has the Linux source and how to add can-utils? I am a little new to building Yocto images. Please help.

open ./meta-swi/meta-swi-mdm9x28/recipes-core/images/mdm9x28-image.inc and add the following line:

IMAGE_INSTALL_append = " canutils"

after that you can type “make” to generate the ./build_bin/tmp/deploy/images/swi-mdm9x28-wp/yocto_wp76xx.4k.cwe

@devanshu.agarwal ,

it seems there is some issue with the source code downloaded at your end. Can you download the source code from the below link and try the build:

Hope this will resolve your issue

Thanks for the steps @jyijyi . I am getting ModuleNotFoundError: No module named ‘_sqlite3’ when I run the make command.

Thanks @Pankaj. I will download it and try building it by adding can-utils.

@Pankaj after downloading the Source code from drive location I am getting same ModuleNotFoundError: No module named ‘_sqlite3’ when I run the make command.

Does this help?

@jyijyi

Tried the suggested option seems its still looking into the python 3.6 directory for the sqlite .so file. his host ubuntu version 16.04 supports python 2.7.12 which does’nt seems to go well with the linux source code

@devanshu.agarwal

as discussed below is the link for the linux image with can-utils:

link to the manifest file:

The above files are for rel 13.1 firmware for WP7608 kindly try this at your end and let me know if you face any issues

for your Host OS you can try installing python3-pip to see if python 3.6 sqlite can later be installed using pip install pysqlite or try to manually install python 2.7.17 from source as per the link linux - How to use Latest Python 2.7.x "The Right Way" on Ubuntu 12.04 LTS? - Super User

if it does’nt work then you can try with ubuntu 18.04 which is my host OS version with python2 version 2.7.17 .

Thanks a lot @Pankaj for sharing the Linux image.

After flashing the shared image I am not able to SSH. Not able to figure out what is causing this issue. Reverting to older Linux solves my SSH problem.

Hi Devanshu,

The file shared earlier seems to be a wrong one below is the link for the correct file:

Manifest file:

Let me know if you still face issues

Hi Pankaj,

Thanks for sharing the updated image. Will test it and share the result.

Hi Pankaj,

I am now able to use can-utils with the updated image!

Thanks for the help.

Regards,
Devanshu agarwal

anyone have wp77xx Linux Dist Source provide? Thanks!!

Hi,

Below is the link for source download:

https://source.sierrawireless.com/resources/airprime/software/wp76xx/wp76xx-firmware-latest-release-components/#sthash.XflhUFxc.dpbs

Thanks & Regards,

Pankaj Sant