DevStudio 3.3: pb in project creation wizzard


#1

Hi,
I recently updated DevStudio to 3.3 and Legato 15.01.
The target management perspective is working well.
But, at the end of project creation wizzard (to create app or component), I got this error: "java.util.NoSuchElementException"
Thinking about a potential workspace compliancy, I have also done the test with a new fresh workspace… but not better…

Any idea ?

Thank you !


#2

It looks like a known problem of DS 3.3, when both Docker and native toolchains are installed on a Linux host.
If you have installed a Docker toolchain, can you give a try after having uninstalled it?
The bug is fixed in incoming DS 3.4 version.


#3

Same error here.
I tried your suggestion and uninstalled docker toolchain, but that does not help.
Anything else I could try?
Thanks.


#4

Please can you elaborate on which versions of DS/Legato you are using?
On which host OS?


#5

i have the same problem, i tried to uninstall docker toolchain but it did not get better. i use linux 32 bit.


#6

Docker/Boot2Docker build mode can only be used on 64 bits host OS (whatever it is Windows or Linux)


#7

I am using Legato 15.01 / Developer Studio 3.3 on an Ubuntu 14.04 32 bit host.

thanks!


#8

Can you consider migrating to a 64 bits OS?
Or is there any major constraint preventing you to do so?


#9

Hi daav.

Many thanks for your response.

There are some other projects we are working on that require Ubuntu 32 bit (otherwise breaking the toolchain).
Off course we could use different machines or virtual machines, but that is usually something that makes working hours a little bit less sunny.

You wrote that Docker/Boot2Docker build mode is not supported on Linux 32 bit - but projects still can’t be created after uninstalling the docker toolchain. Are there additional restrictions, maybe?

Anyway, if you are saying that DS won’t work under Linux 32 bit, then we just have to accept it and work under Linux 64 bit.

Best regards!


#10

Docker/Boot2Docker definitively can’t work on 32 bits architecture.
Concerning native build, delivered packages only contain tooling (toolchain and other CLI native tools) built for 64 bits architecture.
We could change that in the future, if it appears that it is annoying a considerable part of the Developer Studio/Legato users, but in short term there is no other solution than grabing the 32 bits toolchain, and rebuild the Legato framework from source.


#11

Hello everyone!

I’m having the same problem, I got the error “java.util.NoSuchElementException”, at the end of project creation wizard.
I just trying create a simple HelloWorld example.

In my case I use Ubuntu 14.04 64 bits.
I have installed Legato 16.1 and 15.10, Developer Studio 4.0.

I followed this link to install my enviroment… source.sierrawireless.com/resour … kit_linux/

Anyone have this error?
What I could try to fix it?

Thank you!!


#12

We’re still struggling to reproduce this issue…
Do you remember the exact workflow?
From what you said: fresh install DS 4.0 + install both Legato 16.01 & 15.10 (with Native toolchains I guess?) + give a try with project creation wizard.
After a DS restart, do you still have the issue?


#13

Hello Daav,

I followed the exactly the tutorial… this link: source.sierrawireless.com/resour … kit_linux/
I don’t know what happened.
I’ll try restart from ground, but now I will consider using the newest ubuntu.

I let you know if works.

[Update]
I delete my VM and restart all from scratch… all works very well, using Ubuntu 14.04 LTS.
Thanks!!!