Can't seem to find the devMode app in Legato 18 WP76xx


#1

If you do the pulldown on the device menu and select Install devMode app, It complains that it can’t find it. And I checked the path it’s looking (in tools in the framework) and it’s right. It’s not there.

Evets


#2

Hi @EvetsMostel

Please can you tell which path is expected?


#3

Same place it was in 17.11 only 18.1.0
$LEGATO\Packages\legato.framework.18.1.0.wp76xx-201803051228\resources\legato\build\wp76xx\tools

When I looked around, there’s a legatoArchive.tar.xz in there and when I extracted the files, it’s in that. So it looks like it just didn’t get extracted from the archive.

After the extraction into the “legato” folder at that level, I can indeed install the debugger and debug code.


#4

Oh I see.
I think you tried to install 18.01 with DS 5.3, which failed (because DS 5.3 is not supporting Legato 18.01), and let the package “half-installed”.

Upgrading to DS 5.3.1 is mandatory before trying to install WP76/WP77 R8 packages (including Legato 18.01)


#5

Actually, no. I tried to update in 5.3, but it died when it started and never got any files. I downloaded 18 when I got 5.3.1 installed.