Can't install DeveloperStudio when having Java 1.8?


I had Developer Studio running on my Windows 7 PC with Java 1.8.0_161, but since I was seeing some issues (clean always failed for example), I decided to remove Developer Studio and do a new install to see if this solved my issues.
Unfortunately the setup fails with the message:

Invalid Java version detected:

Error: Registry key ‘Software\JavaSoft\Java Runtime
has value ‘1.8’, but ‘1.7’ is required.
Error: could not find java.dll
Error: Could not find Java SE Runtime Environment.

Legato Application Development Kit needs Java 8 64-Bit to be installed in order to run correctly.

Setup will now exit.

I’m using the following installer: legato-17.11.0-R7-WP77-windows.exe

Can’t Developer Studio indeed not run with my Java version? Or is this a bug in the installer (since Developer Studio was running before on my system, and the information on the Source suggests 1.8 should work as well).
Any ideas how I can get Developer Studio installed on my system again?

Best regards,


Hi @isabelv

I would suggest you to verify/install again your Java version, as suggested on the Windows page:

Please can you tell which specific version of DS you’re trying to install?

Hi Daav,

I checked the version again. This looks good:

java -version
java version “1.8.0_161”
Java™ SE Runtime Environment (build 1.8.0_161-b12)
Java Hotspot™ 64-Bit Server VM (build 25.161_b12, mixed mode)

I removed and reinstalled Java anyway, but get exactly the same behavior afterwards.
Next to Java 1.8.0_161, I do have an older Java version (7) installed (to keep other programs working). Can this cause problems?
I’m trying to install Legato 17.11.0, which I downloaded via the site you refer to. I also tried installing Legato 16.10.4, but this installer shows exactly the same behavior.

Any other suggestions to fix this issue?

Thanks in advance,


Hi @isabelv

Please can you have a try to check java -version into a cmd launched as Administrator?
As the installer itself runs as Administrator, I suspect some kind of bad config synchronization between your regular user account and the Admin account.
That said, even if this supposition is confirmed, I’m not sure of how to fix this…
Maybe by removing the Java 7 install?..

Hi Daav,

You were totally right. When I launched the cmd as Administrator it threw me the same error as Developer Studio did. I eventually solved it be removing and reinstalling the Java 7 versions (since I need them for other applications).

Thanks for your help!


1 Like