Bug in the firmware, Yocto or my bb file?


#1

Hello,

I’ve built a Yocto (swi-mdm9x15) image based on the attached bb file.
blackbox.bb.txt (4.1 KB)

I made several modifications in my application and suddendly saw that useradd command didn’t work anymore when flashing the image.
More precisely, users were added to /etc/shadow but not in /etc/passwd not in /etc/group. I tried to reset it, flash a swi-mdm9x15 stock image, reflash my image … Nothing!

Well, as I had a newly bought FX30, I tried to flash my image on it and everything was working, notably I found my added users. … For some days!

Because today I face the same problem as with my first FX30: flashing the image doesn’t “completely” add the users, I find them in /etc/shadow but not in /etc/passwd nor in /etc/group!!

Can anyone explain what happens and how to get it working back ??

I tried a Factory Reset with the button, erase the user partition with FDT. Nothing!

I just noticed that if I execute useradd by hand on the FX30, then I can flash the image and so my files will have the right owner:group. Strange no??

Alain


#2

Hi @AlBo,

I think you’re facing an issue because of the union fs, and the fact that when /etc/passwd (and /etc/group is modified, it ends up being stored on /mnt/flash (where the top layer of the unionfs is).

If you update the rootfs (= underlying union fs header), you won’t see the new version because the unionfs is hiding them.

To take your updated version, you can eventually wipe /mnt/flash or just remove these files from the unionfs. That would be in /mnt/flash/ufs/etc/ from memory.


#3

@CoRfr,

Well my problem today is that I cannot connect to the FX30 anymore via USB, even after flashing the stock SWI9X15Y_07.12.09.00 image !!! (it seems flashing process runs well so USB is working)

So I cannot test anything anymore unless you know a possibility for a very hard reset or something like that.


#4

@CoRfr,

Hello, the update WP85/WP75 R15 / Legato Recovery Tooling for Windows (5.1.1604.win32-201704191016) allows me to connect back to my FX30, so that’s quite a good news.

But it doesn’t solve the problem with useradd. It’s even worse because with preview version, after creating the user by hand on the target, re-flashing the image correctly set owner:group on concerned files but no more!!!


#5

We tried in WP85 MangOH green board with release 15.
yes, we observed that when /etc/passwd and /etc/group is modified by adding new user by ‘adduser’ command, it ends up being stored on /mnt/flash with user created.
when we tried to delete the file which is created by the new user MangOH green board was restarting continuously after some time not able to connect via ssh.Able to connect after re flashing image.
please share the steps followed.