USERADD_PARAM_${PN} doesn't create the users


I try to create new users in my project but cannot see them on the target.

I declared the rules like that:

inherit useradd
GROUPADD_PARAM_${PN} = "configuration"
USERADD_PARAM_${PN} = "-d /tmp -G configuration blackbox; -m -d /tmp -s /usr/sbin/ -G configuration -p wtmoOHy.mTsUk technicien"

I’ve declared my recipe in /home/xool/yocto/meta-swi/meta-swi-mdm9x15/recipes-core/images/

So I find a passwd file with the expected users in /home/xool/yocto/build_bin/tmp/work/swi_mdm9x15-poky-linux-gnueabi/mdm9x15-image-minimal/1.0-r0.0/rootfs/etc, same for group about the groups I create.

Is it the right place ?

Anyway, once on the target, I find my users in /etc/shadow but nothing in /etc/passwd nor in /etc/group.



yes.If you have not found anything on the /etc/passwd there can be reason that user account is invalid or it will lists only the logged in users.
or user account might be locked./etc/shadow contains encrypted password information of the user id which is present in /etc/passwd.
As /etc/passwd file is accessible by everyone hence critical informations are stored in shadow file of the system.

I don’t really understand.

I n fact that worked for a while and suddendly stopped to create the users defined in the bb file.

I tried to execute useradd by hand once the FX30 started and that worked as expected.

so it seems Something doesn’t work well during boot or preboot … I don’t really how these devices boot up and when useradd is really executed.