[WP7605][SW] Testing 8-wire UART1 by ioctrl( )

Back Ground:
We received Release-17 FW that will be released officially after 1 month, and it supported ioctrl( ) for UART1(ttyHS0).
Customer would like to confirm 8-wire UART1 control as DCE function(continue communication via UART1), but they faced 2 issues as follows.

(1) Automatically reboot
(2) CTS could not keep to out

Please see the attached source code, this is made by native C source.
(Sorry we could not prepare test environment by using native-C code, we can only support legato platform.)

wptestapl.c (1.3 KB)

Regarding to 1, if they change “#if 0” in line-58, module have never been caused automatically reboot.
However, CTS could not be outed in this case, so we would like to know how to improve those issue.

Could you please check the attached source code why UART1 could not keep to be output?

Best Regards,

— Hiroki

I think you should test on FW17 official release

Yes I know, but Sierra requested whether R17 ioctrl() worked correctly as customer’s requirement.
This is customer validation status.
So we would like to know whether issue was caused by either source code or yocto FW.

Sorry for inconvenient you, but please cooperate us to support it.

We use this test app to test
UART_Test1 (1).rar (105.3 KB)

BTW, do you have the test build for FW R17?
If no, it is meaningless as the fix is on R17.

We use this test app to test

Yes I know, and we also confirmed that ioctrl() was worked correctly in legato platform.
However, this source code as requested was made by native-C, so I asked it…

BTW, do you have the test build for FW R17?
If no, it is meaningless as the fix is on R17.

Yes, I have test build for R17 as WP76xx_Release17_BP1_GENERIC_test.exe and Test_yocto.cwe.
Here is AT command return as ATI8.

Legato Ver: 20.04.0_349341965c89cfad976e2ba86246eaab
Yocto Ver: SWI9X07Y_jenkins-Mdm9x28-Review 2020-07-21_08:26:46
OS Ver: Linux version 3.18.140 (oe-user@oe-host) (gcc version 7.3.0 (GCC) ) #1 PREEMPT Tue Jul 21 08:02:27 UTC 2020
LK Ver: SWI9X07Y_jenkins-Mdm9x28-Review
RootFS Ver: SWI9X07Y_jenkins-Mdm9x28-Review 2020-07-21_08:26:46
UserFS Ver: unknown
MCU Ver: unknown

the fix is in yocto side, so you can copy the code of that UART1_test.rar and try that in your native C code.

Also you might try your code in legato application and see if problem exist.