App uninstalled after rebooting WP module

Hi all,

My app is removed from target device every time I reboot the device. If I install it on device, it’s up and running properly. But it’s missing if I reboot the device.

This app uses a service provided by another user app. But if I modify the helloWorld sample app to use the same service, the helloWorld app remains installed even after rebooting. I am confused. The misbehaving app uses merely the functions from le_gpio.api. Cannot come up with any cause.

1 Like

Try running legato status at various times to see the number of your system. If the number increments without you installing a new system then your system has probably rolled back.

Note that you can install the devMode app to almost disable the rollback feature, cf Developer Mode - Legato Docs


I tried to reboot the board to see whether the number increments. It did increment even though I did not reinstall the system @dfrey. And I already installed devMode, but the rollback seems not to be disabled @CoRfr. I found the gdbserver was not packed with devMode when devMode starts. This is solved by including the devMode tool in default.adef and rebuilt the framework.

The fact that devMode is not shipped with the default.sdef is normal, but what I’m concerned is that it seems that your devMode app is not starting properly, which could cause the rollback.

Could you eventually provide some logs (like logread | grep devMode or something like that)?
Also, the fact that gdbserver is not packaged with devMode wouldn’t be solved by adding that to the default.sdef.
What’s more likely is that your toolchain is outdated/not matching your firmware version and does not ship gdbserver.

1 Like

Hi @CoRfr, You are right the gdbserver problem is not solved, here are logs when I restart the devMode app.

Jan 6 00:21:06 | supervisor[470]/supervisor T=main | app.c app_Stop() 2865 | Stopping app ‘devMode’
Jan 6 00:21:06 | devMode[798]/framework T=main | LE_FILENAME TermSignalHandler() 561 | Terminated
Jan 6 00:21:07 | supervisor[470]/supervisor T=main | app.c HardKillApp() 1015 | Hard killing app ‘devMode’
Jan 6 00:21:08 | powerManagerService[838]/powerMgr T=main | le_pm.c OnClientDisconnect() 210 | Releasing wakeup source ‘legato_devModeApp_798’ on behalf of pid 798.
Jan 6 00:21:08 | powerManagerService[838]/powerMgr T=main | le_pm.c OnClientDisconnect() 218 | Deleting wakeup source ‘legato_devModeApp_798’ on behalf of pid 798.
Jan 6 00:21:08 | supervisor[470]/supervisor T=main | apps.c DeactivateAppContainer() 348 | Application ‘devMode’ has stopped.
Jan 6 00:21:08 | supervisor[470]/supervisor T=main | proc.c proc_Start() 1234 | Starting process ‘devMode’ with pid 1199
Jan 6 00:21:08 | supervisor[1199]/supervisor T=main | proc.c proc_Start() 1199 | Execing ‘devMode’
Jan 6 00:21:08 | powerManagerService[838]/powerMgr T=main | le_pm.c le_pm_NewWakeupSource() 344 | Created new wakeup source ‘legato_devModeApp_1199’ for pid 1199.
Jan 6 00:21:08 | devMode[1199]/devMode T=main | devMode.c _devMode_COMPONENT_INIT() 113 | ‘/bin/gdbserver’ has not been packaged with this app, usage of gdbCfg is not possible

The reason that I did not notice this is after reinstall the system including devMode in default.sdef, the rollback problem disappears. So I did not check if devMode starts properly again.

Regarding the toolchain, I installed the firmware by the combined image from wpfirmwarerelease in the first place. Later I installed Legato 17.7.01 framework downloaded from Legato Downloads onto the board. It said on this site that

Release 17.05, 17.06 & 17.07 Note: The Linux OS Source and Toolchains remain unchanged. Download the previous version (SWI9X15Y_07.12.09.00, 32-bit Toolchain or 64-bit Toolchain) to get started with the 17.05, 17.06 & 17.07 Release of the Legato Platform.

So the toolchain should be up-to-date in my perspective.

The first line of the logs you posted is “Stopping app ‘devMode’”. Was there something that happened in the logs previously that gives any indication why devMode is stopping? It seems like the supervisor is killing it.

I don’t think so. I restarted the devMode app so maybe that’s why this log
is diaplayed.