4G dial-up Internet access

Hi, In addition to using “cm data connect”, is there any other way to get online? For example, can the ppp command implement 4G dial-up Internet access on WP?
Thank you.
tao.

I think you can use atd99**1# to dial up on AT command port.
Or you can use AT!Scact=1,1 to establish data channel.

Thank you very much for your answer.
AT!Scact=1,1 There is a problem, is it still necessary to set other settings?

seems it is not registered to network.
Please check at!GSTATUS?
and please set APN by AT+CGDCONT command.

Used AT+CGDCONT=1,“IP”,“CMNET”. But no effect, the same error will still occur.

no problem is found on my side, you can try differnet operator.

ati3
Manufacturer: Sierra Wireless, Incorporated
Model: WP7609
Revision: SWI9X07Y_02.28.03.05 000000 jenkins 2019/07/08 11:04:16
IMEI: 359782080100373
IMEI SV: 6
FSN: WA803370311610
+GCAP: +CGSM

OK
at!gstatus?
!GSTATUS:
Current Time: 449 Temperature: 35
Modem Mitigate Level: 0 ModemProc Mitigate Level: 0
Reset Counter: 1 Mode: ONLINE
System mode: LTE PS state: Attached
IMS reg state: NOT REGISTERED IMS mode: Normal
IMS Srv State: NO SMS,NO VoIP
LTE band: B3 LTE bw: 20 MHz
LTE Rx chan: 1385 LTE Tx chan: 19385
LTE CA state: INACTIVE
EMM state: Registered Normal Service
RRC state: RRC Idle

PCC RxM RSSI: -63 RSRP (dBm): -91
PCC RxD RSSI: -93 RSRP (dBm): -130
Tx Power: 0 TAC: 0462 (1122)
RSRQ (dB): -7 Cell ID: 06745D16 (108289302)
SINR (dB): 15.4

OK
at+cgdcont?
+CGDCONT: 1,“IPV4V6”,"",“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,0,0

OK
at+Cgdcont=1,“IP”,“hkcsl”
OK
at!scact=1,1
OK

That may be that there are other settings on my side that are not doing well.

ATi3

Manufacturer: Sierra Wireless, Incorporated
Model: WP7608
Revision: SWI9X07Y_02.25.02.01 000000 jenkins 2019/01/30 08:13:05
IMEI: 352913090134253
IMEI SV: 6
FSN: XG909301700910
+GCAP: +CGSM

OK
AT!GSTATUS?

!GSTATUS:
Current Time: 4155 Temperature: 39
Modem Mitigate Level: 0 ModemProc Mitigate Level: 0
Reset Counter: 1 Mode: ONLINE
System mode: LTE PS state: Attached
IMS reg state: UNKNOWN IMS mode: Not Support
IMS Srv State: UNKNOWN SMS,UNKNOWN VoIP
LTE band: B3 LTE bw: 10 MHz
LTE Rx chan: 1506 LTE Tx chan: 19506
LTE CA state: INACTIVE
EMM state: Registered Normal Service
RRC state: RRC Idle

PCC RxM RSSI: -49 RSRP (dBm): -80
PCC RxD RSSI: -54 RSRP (dBm): -86
Tx Power: 0 TAC: 57DA (22490)
RSRQ (dB): -14 Cell ID: 0C10E821 (202434593)
SINR (dB): 2.2

OK
AT+CGDCONT?

+CGDCONT: 1,“IP”,“CMNET”,“0.0.0.0”,0,0,0,0

OK
AT+CGDCONT=1,“IP”,“CMNET”

OK
AT!SCACT=1,1

+CME ERROR: no network service

is this china network?
is it ok for cm data connect?

Yes. “cm data connect” is OK.

is it because both “cm data” and AT!SCACT are using same profile ID 1?
Have you tried to activate the AT!SCACT by profile 2? (of course you need to set up APN for profile 2)

BTW, are you typing AT!SCACT in USB AT command channel?

Hi.I can’t understand about the profile ID,and I want to know how to activate the AT!SCACT in profile 2.could you please explicate about that Concretely.

please download and have a look on AT command user guide.

Hi,I want to know if the StartPPPInterface command can implemented after the ATD99**1# on WP

I have only tried pppd in uart data mode, not sure about AT commad mode …

HI, which device under /dev/ you use?
I saw /dev/ttyACM4 in the Legato source. I didn’t find this on the WP76 board. Thank you for your answer.
20191105

I did this.How to connect Developer Studio via UART2 of module.docx (360.1 KB)

Thank you, but we have used this method and can’t solve our current Internet problems.

What is your problem actually?

I hope that through ATD and pppd, WP can access the Internet and achieve the same effect as cm data connect.

The ultimate goal is not to use the cm data connect provided by Legato or the Internet API provided, I want to do something in common, not just run on WP.