WP8548 UPDATE not found

I would like to mark manually my application good using the command
update --mark-good

But I am getting the error

-sh: update: not found

Please note that the update bin is available in /legato/systems/current/bin.

Could anyone please respond why update command is not working.

I am using legato firmware 16.10.4 and WP8458 firmware as pasted below

how about using “/legato/systems/current/bin/update”?

Tried using “/legato/systems/current/bin/update”, but still I get the same error. Any other suggestions?

Maybe go to legato folder do a
source bin/configlegatoenv
export DEST_IP=

then try to do the update --mark-good

HI @abhijitpatil19751,
did you try the proposal?
does it solve your issue?
best regards,

We are using wp7502 module. When we try update command in terminal it is working without any errors.But when we tried to use it in code using system command it is showing “update not found”.Can u help me to resolve this issue.
thanks and regards,

Update command normally only works after cfglegato has been executed.
If you open .bashrc you will find cfglegato is an alias:

alias cfglegato="pushd . && cd ~/legato_framework/legato && source ./bin/configlegatoenv ; popd"

If you open configlegatoenv you will see that it adds a bunch of directories to your PATH.

export PATH=$LEGATO_ROOT/bin:$PATH:$LEGATO_ROOT/build/localhost/framework/bin

If you want to use update from a system command you either need to execute configlegatoenv or add these entries to your PATH manually.
Otherwise you can use a full path to the update command.


Nevermind. I realised you are talking about executing update from on the WP7502.
The concept is the same, your terminal knows where update is, the system command does not.

Either add /mnt/legato/system/bin to your PATH or use the full path /mnt/legato/system/bin/update

We couldn’t find .bashrc file.

But when we added the path before update in the system command it worked.

Hi @abhijitpatil19751 @Sahithi,
is this issue solved?
best regards

Yes the issue is resolved.

Thanks for your help.



Yes, It is solved.