Sample gpsApp usage

Hey I have a magOh yellow device which has 21.05.0_0e0fd5f3fc5f6169e2516f22304da11c_modified in it. On development environment I have got legato version 21.05 as well. I can build and run the sample gpsApp without any errors but it doesnt do anything in the documentation it says I can use map locate function I tried to use it and couldn’t. I need help there and also I tried to check if the app gets stuck or not using LE_INFO() function It didnt print even hello World. I am confused about gpsApp and how to use it please help. Thanks in advance.

have you tried with AT!GPSFIX command first?
Or have you tried with gnss command first?

gnss get loc2d and 3d works fine I havent tried at!gpsfix should I try it? And maybe I am using map locate function wrong any guidelines would be great other than the one on the documentation.

if gnss command is working fine for you, you can refer to the source code of gnss command here:

For the gpsApp, did you build the whole system by the .sdef file?
here says:

Oooh so that means I have to use mksys I was using mkapp to build my applications.