Problem when running "Hello World" as Legato Application


#1

Hello,

When I attempt to run the Hello World application I keep getting this error:

An internal error occurred during: “Launching [Launch] helloLegato - hellolegato - Target_Legato_Debug”.
java.lang.NullPointerException

If someone can explain to me what the issue is and how to resolve it, it would be very much appreciated.

Thakfully
Kas


#2

Hi,

please can you elaborate on how do you try to launch it?
with current Developer Studio versions, the good way should be right-click on the project > Run As… > Legato Application
By the way, please can you tell which DS version you’re using, and on which host OS?

Thanks.


#3

Eclipse usually throws up java errors like that when there is something in the environment it doesn’t like. A common cause is running 32-bit eclipse on a machine with 64-bit java only, or vice versa. Google “Eclipse throws a java.Lang.NullPointerException”.


#4

Hello,

I am using Legato 16.07 on Ubuntu 16.04.1. I downloded the VM from mangOH.io on Nov 3 2016. As for how I am running the app I am doing as you say as far as I know. I am following teh getting started from mangOH.io. The error I am getting must be from the IDE as the code is written in C, again its just following teh getting started guide from mangoh.io.

Thankfully
Kas


#5

Hi,

I have the same issue, ubuntu 14.04 LTS 64 bits, java openjdk 1.8.0_91 64 bit Server VM.
Developer Studio 4.1.

I initially had Legato 16.1 and 16.4 installed.
I ran the HelloWorld onto my FX30 (FW SWI9X15Y_07.11.09.00 … 2016/08/11), followed the GettingStarted, all worked well.
I got a prompt before running on the target saying that my target had a newer FW than the legato version, and if I want to run the app anyhow. I did hit yes. App ran properly.

I then installed legato 16.7 on my studio, created a new HelloWorld project in 16.7, tried to run it and I get this same java null pointer exception. Funny is now even if create a project in 16.4 I still get the error.


#6

I ended up updating everything, I have a blog post on how to do this.

I hope this helps.

Kas


#7

thanks for the answer and tutorial Kas!

like you mentioned I reinstalled everything and i can now create apps properly with legato 16.07.
I followed this link from Sierra:
http://source.sierrawireless.com/resources/airprime/software/legato_application_development_kit_linux/

Bottom line is the 16.07 only works with Studio 4.1.1 and this one gets only installed on a Ubuntu 16.04. Not on a Ubuntu 14.04.
In fact I tried the same link above from the SierraWireless Source on my other laptop running Ubuntu 14.04 and it ended up installing the 4.1 Studio and the 16.4 legato framework.
(in 14.04 I had to tweak the unzip command line from “unzip legato64 -d ~/legato” into “unzip “legato*##*.zip” -d ~/legato” though).
Whereas following the same procedure from this same Source link on a Ubuntu 16.07 did install the 4.1.1 Studio and the 16.7 legato framework.