Problem when building from swi-linux source (repo safety)

This is something new I have just noticed when building from swi-linux source for the swi-fx30-catm_3.0.0 :
fatal: detected dubious ownership in repository at ‘/home/claudio/yoctoNew/swi-linux-src/meta-swi’

I don`t get this problem with the latest swi-fx30-catm_4.1.0 and I was reading online it seems related with some new safety changes implemented in git…? The swi-linux source was just downloaded today so I wonder if anyone has experienced the same issue?

Does this help?

I did see that but I am unsure about what to do, as first of all I have restart the environment from scratch and still doesn`t work, it trows the same error.
I was able to build a couple of days ago and now it doesn’t, I am not executing from sudo rights so I couldn’t find the answer on the stack overflow post you have linked above.
Also running the command:
git config --global --add /home/claudio/yoctoNew/swi-linux-src/meta-swi-extras

doesn’t solve the problem, I can’t find the .git folder anyway and this should be a repo, not sure if the command would be different.

This happens when I try to build the fx30 image from source:
make PROD=fx30

This works fine with the new R15 release, not sure if there was some change with the other repo…

How about " use git config --global '*' “to bypass the security measures”?

Here also says to use “chown -R” :

git config --global ‘*’
warning: has multiple values
error: cannot overwrite multiple values with a single value
Use a regexp, --add or --replace-all to change

do these help?

Here also says to use “chown -R” :

I can get past that, but I get odd errors which I have not seen before.

ERROR: linux-quic-3.18.140-r1 do_add_mbnhdr_and_hash: Function failed: do_add_mbnhdr_and_hash (log file is located at /home/claudio/yoctoBase/swi-linux-src/build_bin/tmp/work/swi_mdm9x28_fx30-poky-linux-gnueabi/linux-quic/3.18.140-r1/temp/log.do_add_mbnhdr_and_hash.16322)
ERROR: Logfile of failure stored in: /home/claudio/yoctoBase/swi-linux-src/build_bin/tmp/work/swi_mdm9x28_fx30-poky-linux-gnueabi/linux-quic/3.18.140-r1/temp/log.do_add_mbnhdr_and_hash.16322
Log data follows:
| DEBUG: Executing shell function do_add_mbnhdr_and_hash
| Error configuring OpenSSL
| 139894268994304:error:25066067:DSO support routines:DLFCN_LOAD:could not load the shared library:dso_dlfcn.c:187:filename( cannot open shared object file: No such file or directory
| 139894268994304:error:25070067:DSO support routines:DSO_load:could not load the shared library:dso_lib.c:233:
| 139894268994304:error:0E07506E:configuration file routines:MODULE_LOAD_DSO:error loading dso:conf_mod.c:271:module=ssl_conf, path=ssl_conf
| 139894268994304:error:0E076071:configuration file routines:MODULE_RUN:unknown module name:conf_mod.c:212:module=ssl_conf
| WARNING: /home/claudio/yoctoBase/swi-linux-src/build_bin/tmp/work/swi_mdm9x28_fx30-poky-linux-gnueabi/linux-quic/3.18.140-r1/temp/run.do_add_mbnhdr_and_hash.16322:1 exit 1 from ‘openssl dgst -sha256 -binary /home/claudio/yoctoBase/swi-linux-src/build_bin/tmp/deploy/images/swi-mdm9x28-fx30/boot-yocto-mdm9x28.2k.img > /home/claudio/yoctoBase/swi-linux-src/build_bin/tmp/deploy/images/swi-mdm9x28-fx30/boot_hash.2k’
| ERROR: Function failed: do_add_mbnhdr_and_hash (log file is located at /home/claudio/yoctoBase/swi-linux-src/build_bin/tmp/work/swi_mdm9x28_fx30-poky-linux-gnueabi/linux-quic/3.18.140-r1/temp/log.do_add_mbnhdr_and_hash.16322)
ERROR: Task (/home/claudio/yoctoBase/swi-linux-src/meta-swi/meta-swi-mdm9x28/recipes-kernel/linux/ failed with exit code ‘1’
NOTE: Tasks Summary: Attempted 4126 tasks of which 4069 didn’t need to be rerun and 1 failed.

And again, I have no changed anything in the yocto folder which I only use to have everything in one file to download firmware and legato application to the fx30.
It was working a couple of days ago and now it does not work anymore, it would be good to understand if this is anything has changed in the repo and is going to be fixed?
Building the swi-fx30-catm_4.1.0 is not giving any error, only the swi-fx30-catm_3.0.0 does.