Platform Build error for raspiberry pi


#1
  1. Installed all the necessary tools mentioned

  2. export RASPI_TOOLCHAIN_DIR=~/tools/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian-x64/bin

3.export RASPI_TOOLCHAIN_PREFIX=arm-linux-gnueabihf-

  1. git clone legato framework

  2. make raspi

  3. The error occurs as follows


#2

Hi @sowvikroy,

note that you should clone legato with repo, cf https://github.com/legatoproject/legato-af#clone-from-github

Then try to also declare the RASPI_SYSROOT env. variable.
It should be able to detect it by itself but it’s failing to do so.
I’ll try to solve this for the next release.

BTW, as a warning, the raspi support is quite unmaintained unfortunately.
It builds but that’s the extend of our testing at the moment.
Please let us know if you encounter any runtime issue.

Thanks


#3

Hi @CoRfr,
I think we got a runtime issue as follows. Could you please help me with this


#4

What is the version of your kernel? (uname -a) ?


#5

Also I tried to make a quick patch that might help with the start-up.
I’ve not tried it though.

From effa880a2677202d53360519df07204e31602d77 Mon Sep 17 00:00:00 2001
From: Bertrand Roussel <broussel@sierrawireless.com>
Date: Mon, 18 Jun 2018 14:50:55 -0700
Subject: [PATCH] Skip memory cgroup

Change-Id: I65c24e1801ac2ff8331456fc328164511bf3a958
---
 framework/liblegato/linux/cgroups.c | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/framework/liblegato/linux/cgroups.c b/framework/liblegato/linux/cgroups.c
index e70058391..bf328525b 100644
--- a/framework/liblegato/linux/cgroups.c
+++ b/framework/liblegato/linux/cgroups.c
@@ -139,7 +139,7 @@ static void MountSubSys
 
         LE_ASSERT(le_dir_Make(dir, S_IRWXU) != LE_FAULT);
 
-        LE_FATAL_IF(mount(SubSysName[subSys], dir, "cgroup", 0, SubSysName[subSys]) != 0,
+        LE_ERROR_IF(mount(SubSysName[subSys], dir, "cgroup", 0, SubSysName[subSys]) != 0,
                     "Could not mount cgroup subsystem '%s'.  %m.", SubSysName[subSys]);
 
         LE_INFO("Mounted cgroup hierarchy for subsystem '%s'.", SubSysName[subSys]);
@@ -873,7 +873,8 @@ le_result_t cgrp_mem_SetLimit
     // Write the limit to the file.
     if (WriteToFile(CGRP_SUBSYS_MEM, cgroupNamePtr, MEM_LIMIT_FILENAME, limitStr) != LE_OK)
     {
-        return LE_FAULT;
+        LE_CRIT("Unable to write memory limit '%s' to '%s'.", limitStr, cgroupNameStr);
+        return LE_OK;
     }
 
     // Read the limit to see if it was set properly.
@@ -885,7 +886,8 @@ le_result_t cgrp_mem_SetLimit
                  readLimitStr,
                  sizeof(readLimitStr)) != LE_OK)
     {
-        return LE_FAULT;
+        LE_CRIT("Unable to read memory limit from '%s'.", cgroupNameStr);
+        return LE_OK;
     }
 
     if (strcmp(limitStr, readLimitStr) != 0)
-- 
2.17.1

#6

Linux raspberrypi 4.14.49-v7+ #1 SMP Thu Jun 14 17:55:17 IST 2018 armv7l GNU/Linux


#7

hi @sowvikroy
for more information please have a look to the following page https://docs.legato.io/latest/raspbianMain.html which describes how Raspi is handled with Legato.
Unfortunately, we could not add more support on Raspi,
best regards