Modprobe ipt_MASQUERADE missing

I am trying to load the ipt_MASQUERADE modprobe on the legato (from shell) and this is not found.
modprobe: module ipt_MASQUERADE not found in modules.dep

Trying to follow this legato doc:
https://docs.legato.io/18_09/wifi_toolsTarget_wifi.html

Does anyone has experienced this when running the wifiApTest?

I remember the NAT function is already working when sharing LTE data to ethernet iot card.

I have tried that but it seems that this part of the code is briking the unit (from the sample app):

RunSystemCommand(“modprobe ipt_MASQUERADE”);

RunSystemCommand("iptables -I POSTROUTING -t nat -o " ITF_WAN " -j MASQUERADE");
RunSystemCommand("iptables -I FORWARD --match state "
    "--state RELATED,ESTABLISHED --jump ACCEPT");
RunSystemCommand("iptables -I FORWARD -i " ITF_LAN " --destination " SUBNET
    " --match state --state NEW --jump ACCEPT");
RunSystemCommand("iptables -I INPUT -s " SUBNET " --jump ACCEPT");
RunSystemCommand("iptables -I FORWARD -i " ITF_WAN " --jump ACCEPT");
RunSystemCommand("iptables -I FORWARD -o " ITF_WAN " --jump ACCEPT");

I am unsure why, but if I run this code, then I can`t ssh into the unit anymore (after reboot), so it possibly changes the routes??
I can get up the the ip forwarding part and can connect from my phone, had to add an extra file for the wlan0 to dnsmasq, but I am kind of stuck with the bridging from wlan0 to eth0 at this stage. The next step would also be to have a proper routing, for which I believe the easiest way is to run this code and the MASQUERADE kmodule.

probably it is changing the ECM interface where you used to do console control?

probably, but I don`t understand how as these commands are only routing from rmnet0 to wlan0, this is why I though of an issue with the ipt_MASQUERADE module somehow…

you enter these commands one by one, and you can find why one makes the problem