Install MQTT on MangOH Yellow


I am trying to install mqtt using the following github link: legato-af/apps/sample/mqtt at master · legatoproject/legato-af · GitHub

But when i look at the first command i don’t find any .sdef file. And when i run the command after that i get an error. Do i need to execute another command the didn’t discribed?

I have a backup in legato19.2.0
mqttSample.sdef (636 Bytes)

Where do i need to place that file? in the mqtt folder or the MangOH folder?

I saw it is placed here:

Now i got the following error when i try to run this command;

how about the release of legato 19.2.0?

I got the same error on that version

i don’t see the data hub stuff in that version

Do i need to upgrade?

you can just take the source code of mqtt sample in legato19.2 and compile the two application for testing.

I got again this error when i try it

it is impossible as there is no data hub stuff in the adef file


i’ve got it working. i just need to do “make wp77xx” in my mqtt folder and than i got the update files which i can upload to my MangOH.

When I run the program I don’t get my mqtt messages in. I have changed the mqtt broker to when I start sending messages manually through mosquitto I recieved the data. but as soon as I run that program I don’t get anything in. I understood from the program that the topic is the id of your mangoh yellow (4L935170660210). I also subscribe to the same topic

you might see this thread and see if it helps:

My program can also do a tcp connection but also doesn’t do it. Into my logread i got no errors or something. I just got some file links created

You can add some debug message in COMPONENT_INIT() and see if the app is really running

I can’t edit my program i got an error in my previouse lines. If i delete the added lines i can execute “make wp77xx” again

I don’t understand what error do you get?

This does not make sense
The original code already has debug message
You should be able to compile that