httpServer sample compile issue


I’m trying to compile the httpServer sample with VSCode. (Target is fx30-cat1)
I have a failure for sslCertComponent:

WARNING: can’t open config file: /opt/swi/SWI9X07Y_02.18.06.00/sysroots/x86_64-pokysdk-linux/usr/lib/ssl/openssl.cnf
Unable to load config info from /opt/swi/SWI9X07Y_02.18.06.00/sysroots/x86_64-pokysdk-linux/usr/lib/ssl/openssl.cnf

And a failure for lighttpd:

Can’t locate in @INC (you may need to install the strict module) (@INC contains: /home/pierre/.leaf/wp76-toolchain_SWI9X07Y_02.18.06.00-linux64/sysroots/x86_64-pokysdk-linux/usr/share/autoconf //usr/lib/perl/site_perl/5.22.1 //usr/lib/perl/vendor_perl/5.22.1 //usr/lib/perl/5.22.1 /opt/swi/SWI9X07Y_02.18.06.00/sysroots/x86_64-pokysdk-linux/usr/lib/perl/site_perl/5.22.1/ /opt/swi/SWI9X07Y_02.18.06.00/sysroots/x86_64-pokysdk-linux/usr/lib/perl/site_perl/5.22.1 /opt/swi/SWI9X07Y_02.18.06.00/sysroots/x86_64-pokysdk-linux/usr/lib/perl/vendor_perl/5.22.1/ /opt/swi/SWI9X07Y_02.18.06.00/sysroots/x86_64-pokysdk-linux/usr/lib/perl/vendor_perl/5.22.1 /opt/swi/SWI9X07Y_02.18.06.00/sysroots/x86_64-pokysdk-linux/usr/lib/perl/5.22.1/ /opt/swi/SWI9X07Y_02.18.06.00/sysroots/x86_64-pokysdk-linux/usr/lib/perl/5.22.1 /opt/swi/SWI9X07Y_02.18.06.00/sysroots/x86_64-pokysdk-linux/usr/lib/perl/5.22.1 .) at /home/pierre/.leaf/wp76-toolchain_SWI9X07Y_02.18.06.00-linux64/sysroots/x86_64-pokysdk-linux/usr/share/autoconf/Autom4te/ line 70.

I’ve tried outside VSCode with a “make wp76x” and I have the same failure.

Any idea ?

Thank you for your help

I cannot compile this httpServer sample in WP76 R10.1 package.
I can only compile it in FW R13 package or afterwards. ( I tried in Developer Studio)

Thank you for your answer.

I tried with a R17, and I have the same issue.

I think it is a toolchain issue: as seen in the logs the path is not corect "opt/swi … ". As the installation has been done with VSCode and leaf, the “opt/swi” folder doesn’t exist.

I’ve found a workaround and the compilation succeeded: a symlink from the leaf installed toochain to the “opt/swi” dir.

But I haven’t found where the wrong path is set …