Error creating hellowWorld

I am following the Getting Strarted Guide and I am trying to create the Helloworld application. I am getting the error below. What’s wrong?


update helloWorld.wp85.update 192.168.2.2
Applying update from file ‘helloWorld.wp85.update’ to device at address ‘192.168.2.2’.
Unpacking package: 100% ++++++++++++++++++++++++++++++++++++++++++++++++++
Applying update: 0%
FAILED

***Error: Internal error during update. See log for details.
Update failed
Systems installed:
4 [good] <-- current
Legato framework is running.

try app install helloWorld.wp85.update 192.168.2.2

"$ app install helloWorld..update "

Update seems to be for updating the system? if that’s what you are trying to do

Hi,
Thank you for your answer.

I have tried “app install helloWorld.wp85.update 192.168.2.2” but it didn’t work:

“root@swi-mdm9x15:~# app install helloWorld.wp85.update 192.168.2.2
Unknown command ‘install’. Try --help.”

I am following the instructions given in the Getting Started Guide ( document 41112261), item A.1.3.
Command “update” worked fine with item A.1.2 ( update RedSensorToCloud).

Using “update helloWorld.wp85.update 192.168.2.2” with “#logread –f “ returns:
“ Jan 6 00:10:23 swi-mdm9x15 user.crit Legato: CRT | updateDaemon[682]/framework T=main | LE_FILENAME file_CopyRecursive() 821 | No such path : ‘…/apps/drTool/read-only/bin/dr’
Jan 6 00:10:23 swi-mdm9x15 user.crit Legato: CRT | updateDaemon[682]/updateDaemon T=main | updateDaemon.c ApplyAppUpdate() 929 | Failed to install app ‘helloWorld<742ff9d390215aa55938a450630271ce>’.
Jan 6 00:10:23 swi-mdm9x15 user.err Legato: =ERR= | updateDaemon[682]/updateDaemon T=main | updateDaemon.c UpdateFailed() 420 | Update failed!! “

It seems a path is missing. What should I do to fix this issue?
Thanks.

Yes sorry I was wrong you can use app install or update for installing apps both work for me not sure what your issue is sadly im not an expert anyways

Hi @Cared,

The “update service” copy and install the app into the target, I guess that the first action has been done with success but the installation doesn’t work.

Can you check please if the “update service” into your target work or not? “update --help” command display the help?

However, you can try to copy the app into the module with :
scp helloWorld.wp85.update root@192.168.2.2:.

And in the module install it :

update helloWorld.wp85.update

Regards