Developer Studio C++ build question

I have gotten my prototype C++ app / component working and deployed to a mangOH Green board, and I have began to extend its functionality.

One of the first things I did was create a new C++ header and source file in the component’s root directory and put a few functions in it.

I then included the header in the main component C++ source file that contains COMPONENT_INIT, and tried to build.

It compiles fine, but I am getting this error on linking:

Target_Legato_Debug/staging/read-only/lib/ undefined reference to `get_timestamp(char*, int)’

Where “get_timestamp(char*, int)” is a function defined in the new C++ header and source file I created.

I figure it may just be some simple setting in Eclipse that I am missing, but I can’t figure out what.

I have tried adding the include path and source path of the new files, but I get the same error.

I have never used Eclipse prior to this so I am a bit out of my element.

Appreciate any help!

Can you attach your sample project here so that I can give a try in developer studio?

Doh I figured it out.

I neglected to include the definition for the new source file in the component’s cdef file.

Still new to working with this ecosystem, thanks for your offer of help though.