Developer Studio 3.3 Problem creating Components


#1

Hi

We cannot create a component with the new version of the developer studio.

New -> Project -> Legato Component Project : the component is not created and this error appears:

"An error occurred during project creation Reason: org.eclipse.core.runtime.CoreException: Failed to creato injector for com.swi.spm.legato.parser.Cdef ExtensionFactory: com.swi.spm.legato.parser.ui.CdefExecutableExtensionFactory"

Also, we can’t edit the project properties because when we do a right button click this possiblity does not appear.
Futhermore, when we try to edit dependencies in the references the window does not appear.

Are we missing a pluggin or something else?

Thank you


#2

We can’t reproduce this behavior on a fresh install.
How did you install DS?
If you have upgraded from DS 3.2, and previously installed the patch proposed here: viewtopic.php?f=177&t=8346, did you uninstall the patch before upgrade?
And if not, please can you provide a text file with what’s in the Help > About Developer Studio > Installation Details > Configuration tab?


#3

Hi daav,

Thank you for your response.

DS is installed (on Linux, Ubuntu 14.04.02) from the developer studio web source, following the alternative method:
http://source.sierrawireless.com/resources/airprime/software/developer-studio-getting-started/

The java version installed on my computer is:

java -version
java version "1.7.0_75"
OpenJDK Runtime Environment (IcedTea 2.5.4) (7u75-2.5.4-1~trusty1)
OpenJDK 64-Bit Server VM (build 24.75-b04, mixed mode)

And this is my java configuration:

$ sudo update-alternatives --config java
There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection    Path                                            Priority   Status
------------------------------------------------------------
  0            /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java   1071      auto mode
* 1            /usr/lib/jvm/default-java/bin/java               1         manual mode
  2            /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java   1071      manual mode

The last thing I did was to upgrade my old DS 3.2 and this is the txt of my configuration tab: http://www.filedropper.com/configurationtab

It seems a plugin error because the “error log” window shows this output:

Problems occurred when invoking code from plug-in: "org.eclipse.jface".

ava.lang.NoClassDefFoundError: com/swi/spm/legato/parser/xdef/RequireSection
	at java.lang.Class.getDeclaredMethods0(Native Method)
	at java.lang.Class.privateGetDeclaredMethods(Class.java:2615)
	at java.lang.Class.getDeclaredMethods(Class.java:1860)
	at com.google.inject.spi.InjectionPoint.getInjectionPoints(InjectionPoint.java:662)
	at com.google.inject.spi.InjectionPoint.forInstanceMethodsAndFields(InjectionPoint.java:356)
	at com.google.inject.internal.ConstructorBindingImpl.getInternalDependencies(ConstructorBindingImpl.java:151)
	at com.google.inject.internal.InjectorImpl.getInternalDependencies(InjectorImpl.java:585)
	at com.google.inject.internal.InjectorImpl.cleanup(InjectorImpl.java:543)
	at com.google.inject.internal.InjectorImpl.initializeJitBinding(InjectorImpl.java:529)
	at com.google.inject.internal.InjectorImpl.createJustInTimeBinding(InjectorImpl.java:847)
	at com.google.inject.internal.InjectorImpl.createJustInTimeBindingRecursive(InjectorImpl.java:772)
	at com.google.inject.internal.InjectorImpl.getJustInTimeBinding(InjectorImpl.java:256)
	at com.google.inject.internal.InjectorImpl.getBindingOrThrow(InjectorImpl.java:205)
	at com.google.inject.internal.InjectorImpl.getInternalFactory(InjectorImpl.java:853)
	at com.google.inject.internal.FactoryProxy.notify(FactoryProxy.java:46)
	at com.google.inject.internal.ProcessedBindingData.runCreationListeners(ProcessedBindingData.java:50)
	at com.google.inject.internal.InternalInjectorCreator.initializeStatically(InternalInjectorCreator.java:133)
	at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:106)
	at com.google.inject.Guice.createInjector(Guice.java:95)
	at com.google.inject.Guice.createInjector(Guice.java:72)
	at com.google.inject.Guice.createInjector(Guice.java:62)
	at com.swi.spm.legato.parser.ui.internal.CdefActivator.createInjector(CdefActivator.java:67)
	at com.swi.spm.legato.parser.ui.internal.CdefActivator.getInjector(CdefActivator.java:55)
	at com.swi.spm.legato.parser.ui.CdefExecutableExtensionFactory.getInjector(CdefExecutableExtensionFactory.java:26)
	at org.eclipse.xtext.ui.guice.AbstractGuiceAwareExecutableExtensionFactory.create(AbstractGuiceAwareExecutableExtensionFactory.java:49)
	at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:262)
	at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:55)
	at org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugin.java:294)
	at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
	at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(WorkbenchPlugin.java:289)
	at org.eclipse.ui.internal.dialogs.WorkbenchPreferenceNode.createPage(WorkbenchPreferenceNode.java:48)
	at org.eclipse.jface.preference.PreferenceDialog.createPage(PreferenceDialog.java:1372)
	at org.eclipse.ui.internal.dialogs.FilteredPreferenceDialog.createPage(FilteredPreferenceDialog.java:385)
	at org.eclipse.jface.preference.PreferenceDialog.showPage(PreferenceDialog.java:1259)
	at org.eclipse.ui.internal.dialogs.FilteredPreferenceDialog.showPage(FilteredPreferenceDialog.java:699)
	at org.eclipse.jface.preference.PreferenceDialog$9$1.run(PreferenceDialog.java:730)
	at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
	at org.eclipse.jface.preference.PreferenceDialog$9.selectionChanged(PreferenceDialog.java:725)
	at org.eclipse.jface.viewers.StructuredViewer$3.run(StructuredViewer.java:876)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:50)
	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:178)
	at org.eclipse.jface.viewers.StructuredViewer.firePostSelectionChanged(StructuredViewer.java:873)
	at org.eclipse.jface.viewers.StructuredViewer.handlePostSelect(StructuredViewer.java:1217)
	at org.eclipse.jface.viewers.StructuredViewer$5.widgetSelected(StructuredViewer.java:1243)
	at org.eclipse.jface.util.OpenStrategy.firePostSelectionEvent(OpenStrategy.java:265)
	at org.eclipse.jface.util.OpenStrategy.access$5(OpenStrategy.java:259)
	at org.eclipse.jface.util.OpenStrategy$1$2.run(OpenStrategy.java:440)
	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:136)
	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3774)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3412)
	at org.eclipse.jface.window.Window.runEventLoop(Window.java:832)
	at org.eclipse.jface.window.Window.open(Window.java:808)
	at org.eclipse.ui.internal.dialogs.WorkbenchPreferenceDialog.open(WorkbenchPreferenceDialog.java:221)
	at org.eclipse.ui.internal.OpenPreferencesAction.run(OpenPreferencesAction.java:66)
	at org.eclipse.jface.action.Action.runWithEvent(Action.java:519)
	at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:595)
	at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:511)
	at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:420)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
	at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4454)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1388)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3799)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3409)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1151)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032)
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148)
	at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
	at com.swi.devstudio.core.Application.start(Application.java:147)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1438)
Caused by: java.lang.ClassNotFoundException: com.swi.spm.legato.parser.xdef.RequireSection cannot be found by com.swi.spm.legato.parser.cdef.ui_3.2.0.201411061551
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:432)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:345)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:337)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:160)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
	... 87 more

eclipse.buildId=unknown
java.version=1.7.0_75
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en
Command-line arguments:  -os linux -ws gtk -arch x86_64 -data @noDefault

Note: Also, the error is reproduced when Preferences > Refactoring is clicked

aweros

PS: I’ve tried to install DS also from the command line:

sudo apt-get install devstudio-legato

But the installation fails with this error:

Setting up devstudio-updater (20130618-1) ...
Setting up devstudio-product (3.3.0.201501281210-1) ...
*** Using updatesite: http://updatesite.sierrawireless.com/developerStudio3
*** Temporary workspace: /tmp/tmp.U1fccMMpaZ
*** Action: install
*** Installing product: com.swi.devstudio.product/3.3.0.201501281210
Installation failed.
Unable to load repositories.
Application failed, log file location: /tmp/tmp.U1fccMMpaZ/.metadata/.log

*** Clean temp workspace: /tmp/tmp.U1fccMMpaZ
Setting up devstudio-legato (3.3.0.201501281210-1) ...
*** Using updatesite: http://updatesite.sierrawireless.com/developerStudio3
*** Temporary workspace: /tmp/tmp.eyUBIV7n7z
*** Action: install
*** Installing feature: com.swi.devenv.legato.feature.group/3.3.0.201501281204
Installation failed.
Unable to load repositories.
Application failed, log file location: /tmp/tmp.eyUBIV7n7z/.metadata/.log

*** Clean temp workspace: /tmp/tmp.eyUBIV7n7z
Setting up libc6-i386 (2.19-0ubuntu6.6) ...
Setting up lib32tinfo5 (5.9+20140118-1ubuntu1) ...
Setting up lib32ncurses5 (5.9+20140118-1ubuntu1) ...
Setting up lib32z1 (1:1.2.8.dfsg-1ubuntu1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...

But the log file doesn’t exist.

Also, I’ve tried in another machine with Ubuntu 14.04.01 64 bits version with the same issue


#4

Most of times, apt-get install gives this kind of issue because of unconfigured proxy settings.
Are you behind a proxy?
If yes, the procedure is to ensure that the http_proxy/https_proxy variables are set in the environment (with your own proxy settings), and to use sudo -E option.

export https_proxy="http://127.0.0.1:1234";export http_proxy="http://127.0.0.1:1234" sudo -E apt-get install devstudio-legato


#5

Hi daav,

Thank you for your help. After a complete unistallation of the devstudio-legato (and also, devstudio-updater & devstudio-product) and using the environment variables to install the devstudio-legato behind proxy configuration, it works:

$ sudo apt-get autoremove devstudio-product devstudio-updater devstudio-legato
$ sudo http_proxy=http://127.0.0.1:1234 apt-get install devstudio-legato

When I run the devstudio, the project->properties option exists and also, it works. Then, I’ve tried again to install Legato packages from the Help->Install New Software (adding the updatesite.sierrawireless.com/developerStudio3/ resource site) but when the installation ends, the project->properties option doesn’t exist :frowning: Of course, I’ve tried to install the legato-af and the toolchain but I can’t create Legato Components.

It seems like the upgrade procedure delete some packages/plugins of the devstudio.

Thanks


#6

If you’ve installed DS through apt-get, you shouldn’t need to go to Help > Install New Software
All you need is already installed by installing the devstudio-legato package.
Then, to install Legato packages, you need to go to the Package Manager perspective.

When you say you can’t create Legato component projects, what is the issue exactly? What is the workflow you’re following, starting from a fresh new workspace?


#7

Thank you very much. The problem was using Help > Install New Software. Using the package installed with devstudio-legato solved the component problem.
Thank you!