Can't find le_mdc.api

Hi, I’m trying to get my Visual Studio code to compile under vscode. I am using R16 release, did all the download with leaf and have selected R16 stable. I’ve selected my app, and tried to build it, but it gets stuck on the first api line:
le_mdc = le_mdc.api

Says it “couldn’t find file le_mde.api”.
What am I missing?


You can see in the sample app modemdemo on how to use the le_mdc.api file

Or you can see the example here on how to use the le_mdc.api and the makefile to compile:

I still get the same error. Here is the error:
/home/steve/Rev16/inseego/ConnMgr/ConnTestComp/Component.cdef:11:2: error: Can’t find dependent .api file: ‘le_mdc.api’.
The terminal process “/bin/bash ‘-c’, ‘mkapp ${LEGATO_DEF_FILE} -s components -t ${LEGATO_TARGET} -w ${LEGATO_OBJECT_DIR} -o ${LEGATO_OUTPUT_DIR}’” failed to launch (exit code: 1).

Here is my .cdef file for api:



Did you see the makefile in the link above?

You need to add more path:

# MK command
MKCOMMAND:=cd ..;mkapp -t $(TARGET) -o Target_Legato_Debug -w Target_Legato_Debug -i "$(LEGATO_ROOT)/interfaces/wifi" -i "$(LEGATO_ROOT)/interfaces/airVantage" -i "$(LEGATO_ROOT)/interfaces/portService" -i "$(LEGATO_ROOT)/interfaces/logDaemon" -i "$(LEGATO_ROOT)/interfaces" -i "$(LEGATO_ROOT)/interfaces/watchdog" -i "$(LEGATO_ROOT)/interfaces/airVantage/legacy" -i "$(LEGATO_ROOT)/interfaces/positioning" -i "$(LEGATO_ROOT)/interfaces/atServices" -i "$(LEGATO_ROOT)/interfaces/secureStorage" -i "$(LEGATO_ROOT)/interfaces/modemServices" -i "$(LEGATO_ROOT)/interfaces/supervisor" -s "$(LEGATO_ROOT)/components/dataConnectionService/platformAdaptor/default" -s "$(LEGATO_ROOT)/apps/platformServices/airVantageConnector" -s "$(LEGATO_ROOT)/components/airVantage" -s "$(LEGATO_ROOT)/modules/WiFi/apps/tools/wifi" -s "$(LEGATO_ROOT)/components/positioning" -s "$(LEGATO_ROOT)/components/secStore" -s "$(LEGATO_ROOT)/components/portService" -s "$(LEGATO_ROOT)/components/uartMode/platformAdaptor/default" -s "$(LEGATO_ROOT)/components/modemServices/platformAdaptor/default" -s "." -s "$(LEGATO_ROOT)/components/audio/platformAdaptor/default" -s "$(LEGATO_ROOT)/components/3rdParty" -s "$(LEGATO_ROOT)/apps/tools" -s "$(LEGATO_ROOT)/components/fwupdate/platformAdaptor/default" -s "$(LEGATO_ROOT)/modules/WiFi/service" -s "$(LEGATO_ROOT)/components/dataConnectionService" -s "$(LEGATO_ROOT)/components/airVantage/platformAdaptor/default" -s "$(LEGATO_ROOT)/components/fwupdate" -s "$(LEGATO_ROOT)/components/positioning/platformAdaptor/default" -s "$(LEGATO_ROOT)/components/devMode" -s "$(LEGATO_ROOT)/components/secStore/platformAdaptor/default" -s "$(LEGATO_ROOT)/components/atServices" -s "$(LEGATO_ROOT)/components/modemServices" -s "$(LEGATO_ROOT)/components" -s "$(LEGATO_ROOT)/components/uartMode" -C -g -X -g -L -g infoTest.adef

Why is this not added automatically?

the default compilation command is just for some very basic app like helloworld, you can see it did not add much .api file.
Actually you can refer the makefile for each sample application:

OK, I guess I wasn’t very clear. I have several projects that have been compiling and working under R13 with Dev Studio. I’m trying to get my code/project to compile under R16 with VsCode.
So, I’m confused. I have makefiles that were generated by the old Dev Studio. Visual Studio doesn’t use those, and there are no other makefiles, and I didn’t get any errors about makefile not found. Where do I hook in a makefile to the project?
How does it even get that far without a makefile?

You can directly use those makefile in vscode, just open leaf shell and type make

OK, then what is the point of using VScode app?
FYI, Doing that yields “mkapp command not found”

It is IDE
You can still work using command line only

Leaf shell should be able to run mkapp