Building Yocto with Legato


#1

I’m writing a legato application that requires libraries that are not in the version of yocto that legato uses, specifically thrift and a legacy library from a previous project. I successfully rebuilt yocto with my necessary libraries. Yocto generated a rootfs, although I have yet to install it.

At this point I’m a little confused, it seems like there is a mechanism to tie yocto to the legato dev environment. Because when I run ‘make image’ I see:
Makefile:18: “Legato: build disabled since ‘/home/sierra/projects/sierra/yocto/legato/’ does not exist”

I did a grep on all Makefiles inside the legato dev environment and it seems like the one located at /home/sierra/legato/packages/legato.framework.16.7.0.201609081601/resources/legato is the correct one, because it satisfied the “sdk” target.

I made a sim link inside the yocto directory legato -> /home/sierra/legato/packages/legato.framework.16.7.0.201609081601/resources/legato

I ran ‘make image’ from yocto. It ran all the way until it got an error with execute permissions on ninja-generator, so I chmod +x ~/legato/packages/legato.framework.16.7.0.201609081601/resources/legato/framework/tools/mkTools/ninja-generator

It got past that error, now I get an error of execute permissions on createSdk:
make: execvp: createsdk: Permission denied

At this point I feel like I’m headed in the wrong direction and wanted some clarification. Is there suppose to be a tight connection between the Legato dev environment and the yocto build? I was speculating that if I created that sym link that when I built yocto it would update the legato dev environment with the update FS/Headers/Lbiraries. Is that true? There is no documentation I can find on how the dev environment and custom build of yocto are suppose to work together so I’m shooting from the hip.

I’m using:
To build yocto I followed http://legato.io/legato-docs/latest/yoctoLegatoOverview.html
Yacto source came from : Legato-Dist-Source-mdm9x15-SWI9X15Y_07.11.09.00.tar.bz2
Legato SDK is from legato-16.07-linux-64bits.zip
My target is a mangoOH board with a WP8548
Host OS ubuntu 16.04


#2

try to use sudo make sometimes it is required to access packages which only “root” can do it.