AirVantage apps don't work


#1

Hello everyone,

I wrote a voice call program, and everything worked well: I could start an outgoing call from the device and could accept incoming calls. It was running without AirVantage.
I didn’t change something in the program code, but since the update to 14.10 the app doesn’t work anymore. It seems like the app wants to connect to AirVantage and after a few seconds it stops automatically.
I send you the logread that was running when I started the app (the start is missing because when I wanted to copy the logread I couldn’t scroll higher) [attachment=0]voice call log.txt[/attachment]
Here is what I get when I check the app status a few seconds after I started it:
root@swi-mdm9x15:~# app start voicecallTest
Starting app ‘voicecallTest’…
DONE
root@swi-mdm9x15:~# app status
[running] airvantage
[running] audioService
[running] cellNetService
[running] dataConnectionService
[running] modemService
[running] positioningService
[running] voiceCallService
[stopped] voicecallTest

When I connect to AirVantage via LUA shell I get the following:

:agent.srvcon.connect()
= “ok”
= nil

And in the logread:
Jan 1 00:10:04 swi-mdm9x15 user.info Legato: INFO | AirVantage[880]/AirVantage T=main | M3DA-SESSION(default.lua) () 78 | Opening default session #2
Jan 1 00:10:04 swi-mdm9x15 user.err kernel: [ 365.175705] NOHZ: local_softirq_pending 08
Jan 1 00:10:05 swi-mdm9x15 user.err kernel: [ 365.655272] NOHZ: local_softirq_pending 08
Jan 1 00:10:05 swi-mdm9x15 user.info Legato: INFO | AirVantage[880]/AirVantage T=main | M3DA-SESSION(default.lua) () 92 | Closing default session #2 with status 200.
Jan 1 00:10:05 swi-mdm9x15 user.err kernel: [ 365.674133] NOHZ: local_softirq_pending 08
Jan 1 00:10:21 swi-mdm9x15 daemon.warn dnsmasq-dhcp[325]: no address range available for DHCP request via eth0
Jan 1 00:10:35 swi-mdm9x15 user.err kernel: [ 395.976560] NOHZ: local_softirq_pending 08

I hope this is enough information for you to help me :slight_smile:

Best Regards,
Daniel


#2

Hi Daniel,

From inspecting your logs, I don’t think this is an AirVantage issue since it is running properly.

The voicecallTest app that you currently have running. Is it a pre-existing app from 14.07? If so, can you try rebuilding it using 14.10? There has been some changes to the .adef syntax in 14.10. And if that still doesn’t work, can you show me your app’s source code?

Thanks,
Enoch


#3

Hi Enoch,

Yes, it is a pre-existing app from 14.07, but I’ve already changed the definition files.
Here is the whole app:[attachment=0]voicecallTest.zip[/attachment]

Thanks for your help!
Daniel


#4

Hi Daniel,

Turns out the issue is from the ConnectVoiceCall function

There is a bug where opening I2S Rx/Tx is only available on the LE_AUDIO_I2S_STEREO channel. To workaround this issue, you can do the following:

Sorry for the inconvenience, hopefully we will have this fixed by the next release.

Also from quick glance, you should remove starting a call from

because while you are making a call to a number (ALERTING - Voice call establishment in progress), you are making another call to the same number again.

Enoch :smiley:


#5

Hello Enoch,

I have another problem: I wanted to start the sample eCall app, but it doesn’t work.
I built Legato for WP7 with the following command:
make wp7 INCLUDE_ECALL=1
So I think eCall should work.
But it doesn’t and I think it behaves differently!?
Sometimes I get the following logs:
[attachment=0]eCall logs 1.txt[/attachment]
And sometimes these:
[attachment=1]eCall logs 2.txt[/attachment]

Can you help me? I didn’t change anything on the eCall sample code except that I commented the lines with “StartTest()” out, because I wanted to look if the app runs before I test the communication (I didn’t want to call an emergency call everytime I run the app :smiley: )

Thank you!
Daniel


#6

Hi Daniel,

The eCall feature is only supported on the AR7 products as noted in the documentation (legato.io/legato-docs/14_10/c_ecall.html - “eCall service is only available on automotive products.”).

Enoch


#7

Hi Enoch,

Is there something like an artificial blockade? Because I thought technically the WP7 is identical constructed like the AR7.

Thank you!
Daniel


#8

Yes, the current WP7 firmware has eCall disabled. When an updated package will be made available is still not determined but I will keep you updated as soon as it is available.