Developer Studio giving error in IDE over valid c++


#1

Hi,

I am trying to use RxCPP to handle the async events of the board, since I am used to use a RX framework on other platforms. I am able to include the header files (RxCPP is a header-only library), and compile correctly a small sample application but the IDE is giving me a lot of errors, even though the compiler works perfectly fine with the code. Is there additional configurations I should be doing to handle this?


#2

Hi @fjanicki

My guess is that you’re using C99 or C++11 coding standards, right?
The static code analysis is not compatible by default with this, which is causing these error markers.

You can change this by going to your project Properties > C/C++ General > Preprocessor Include Paths, Macros, etc. page.
Then select the Providers page, and pick the Legato Linux GCC Built-in compiler settings entry in the list.
Then add the -std=c++11 option to the command line, as shown in the picture below:

Then close the dialog, and trigger right-click > Index > Rebuild then right-click > Run C/C++ Analysis on your project.
The analysis errors should disappear.

Please note that from distributions based on a Yocto 2.2 version, this standard is enabled by default in GCC, and there is no need to upgrade the settings in Developer Studio.
(At the moment (January 2018), the only release in that case is Release 7(Legato 17.11) for WP76 and WP77)


#3

Oh yeah! Thank you so much! You are a real life saver. I would never have found this on my own, as I thought adding the compiler flag to the .cdef was enough.

Any idea when the 2.2 version will be available for WP85XX SoCs?


#4

You’re welcome :wink:

Well, I’ve heard about sometime in Q2 this year, to be confirmed.

In the meantime, we’ll have a look if we can automate this kind of Provider settings for Yocto 1.7 based toolchains in a next DS release.