Trouble upgrading to 14.04?


#1

Post your questions and issues in this topic and we’ll help you out.


#2

Hiya,

I tried to upgrade my AR7 to the 14.04 version of the legato framework. I had some problems at first, but now everything seems to be working except for one thing :

There is an error message which prompts twice every 4 seconds into the serial output after the boot routine :

Does anyone have an idea how to solve this problem ?

KR,


#3

Hi,

Just to clarify, when you upgraded to 14.04 version of the legato framework, did you only upgrade the legato framework or also the modem firmware?

Also to remove the error message, try creating “APSS_UART_INTERFACE_SRV” in /mnt/userrw/swinv/.
$ touch /mnt/userrw/swinv/APSS_UART_INTERFACE_SRV

We have never seen the above error before, but that should fix it for now. I’ll see if it’s reproducible once you give me some feedback on what you did during your upgrade process.

Thanks,
Enoch :smiley:


#4

Actually, this is apparently a known issue when upgrading AR7’s firmware from 06.02.07.00 -> 06.02.15.00+.


#5

Hi,

Indeed, I had this problem after upgrading the modem firmware from 06.00.04 to 06.02.16.00 (with the AR7 module)

Creating the file APSS_UART_INTERFACE_SRV solved the problem of the prompting message (strangely :unamused: )

If you have any updates on this issue don’t hesitate to post on this topic !

Thanks,