Speaker and Mic not responding


#1

Hello All,
I am Using Wp7104 module .

I have integrated my module to development kit of Airprime module WP-AR series
I have connected the speaker phone available with the kit to J300 connector .

I am able to send the AT commands from minicom for basic communication testing .
But when i send a ring command i wont hear any ringing sound from phone … But in the console it shows the cal incoming .

[code]RING

+CLIP: “+919916200276”,145,0

RING

+CLIP: “+919916200276”,145,0 [/code]

I changed the headset which was supplied with the kit and tested with other . Still the same issue is there

i have tested the same test with one more WP7104-G module in which legato firmware is not running but i am able to get the ring sound .
Both the modules are with the firmware (06.03.32.00)

Kindly help out with the issue .

Regards
Shruthi


#2

Hi,

are you using version 15.01 ?

The WP7 doesn’t have an internal codec, so you need to make sure that the codec located on the dev kit is:

  • powered: for that, turn SW300 on and make sure the associated green LED is on
  • connected to J300: for that, the 4 jumpers close to J300 (known as JP300->303) are selecting “DIG” (for digital)

If you have that and it is still not working, you can use a tool called “wm8940_demo” on target to switch between “–pcm” and “–i2s”.
This should stimulate the codec and you might be able to hear things from the phone (it would ‘crack’ a bit when switching configurations).

As for the ringing sound, I’m not sure there is one with Legato, unless you implement it in an application.

Bertrand


#3

yes we are using 15.01. I rechecked with firmware version 6.03.39(one corresponding to 15.01) and switching to I2S. I am able to hear the uplink and downlink call but ringing sound is not heard in the phone.
I reconfirmed the firmware where the ringtone was heard it was 6.0.14 but in 6.03.39 , ringing is not heard.
could you please let me know the reason for this.