[solved] Cannot find pa_audio_default with meaningful content


I’m trying to make audio work in our project without using the legato framework as we have some standard linux programs which needs access to the audio interface. Therefore I have taken some time investigating the codec driver and found out somewhat what settings the amix command is setting and which settings to set to make the codec work for both input and output.
However, i’m currently at a loss for how to unmute the microphone device (seems some of the settings for the audio input is only set on unmute and therefore I need to unmute the device to actually be able to record anything). I therefore thought that I would investigate how legato goes around the unmuting since it obviously work here. But alas I haven’t been able to find a version of pa_audio_default.c which actually store any functionality. Anyone know where to find it, something is obviously compiled to the target, but I cannot identify how?

how about using AT command to play/record audio?
I remember I used the following for WP76:


//to stop the audio

Can’t do that since the reason for me to want to use normal alsa is that I need to use a linux streaming application so I need to have access directly to the soundcard / codec for recording audio and streaming it.

I remember aplay works by following this

Maybe you can ask in that thread.

I have tried sending a message to the guy stating that he have gotten it to work as I am very reluctant in waking up dead threads to ask for an out of topic question. But I would like to get his attention non-the-less

@selberg just helped me figuring this out by telling me their approach of getting the codec to work. I can’t tell why I did not think of that my self, its so obvious.
He simply took the amix command and made it dump all the settings:

for i in {1..326}; do amix $i; done

Then he enabled the input by using legato and while it were recording he used amix do dump the settings again. And then, by comparing the two outputs, he were easily able to figure out which amix settings needed to be set to make it work.
And by doing that I also were able to figure out the exact settings needed to be set for input to work and make a bash script setting them.

Thank you all for the help.