[Solved]Build custom Legato/Yocto Image - elfutils_0.158.bb Error


#1

Hello,

I am new to Legato and I tried to build a image which I could flash to the WP8548. In the beginning, just an “untouched” version, later I want to add vpn…

I started with the following page:
http://legato.io/legato-docs/latest/yoctoLegatoOverview.html

I downloaded the Legato Linux Source Distribution (https://source.sierrawireless.com/resources/legato/legatolinuxdist/) and run the following commands:

tar xvjf Legato-Dist-Source-mdm9x15-SWI9X15Y_07.11.21.00.tar.bz2
cd yocto
make

The Problem is I get the following error:
> Makefile:516: recipe for target ‘eblobjnote.o’ failed

    make[2]: *** [eblobjnote.o] Error 1
    make[2]: *** Waiting for unfinished jobs....
    make[2]: Leaving directory '/home/kilian/yocto/build_bin/tmp/work/x86_64-linux/elfutils-native/0.158-r0/build/libebl'
    Makefile:461: recipe for target 'all-recursive' failed
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory '/home/kilian/yocto/build_bin/tmp/work/x86_64-linux/elfutils-native/0.158-r0/build'
    Makefile:376: recipe for target 'all' failed
    make: *** [all] Error 2
    ERROR: oe_runmake failed
    WARNING: /home/kilian/yocto/build_bin/tmp/work/x86_64-linux/elfutils-native/0.158-r0/temp/run.do_compile.30251:1 exit 1 from
      exit 1
    ERROR: Function failed: do_compile (log file is located at /home/kilian/yocto/build_bin/tmp/work/x86_64-linux/elfutils-native/0.158-r0/temp/log.do_compile.30251)

Unfortunately it is not possible to upload the log file as a new user… So i just uploaded it on pastebin:
https://pastebin.com/itgFVJUA

Thanks for your help!

Edit: Using Ubuntu 16.10 with gcc 6.2.0


#2

Using Ubuntu 14.04, which is a supported version for yocto 1.7.2 fixes the problem. :slight_smile:
(Probably glibc and gcc are too new in Ubuntu 16.10)