Legato 15-10 Build error


#1

Hello,

i tried to build legato on Ubuntu 14.04 an i get Bad Substitution error while Compiling legato-af for ar7.
I already checked if i’m using the linux bash.

Can anyone give me a hint how to fix this issue?

Thx, Rene

[i]NOTE: Preparing runqueue
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
ERROR: Function failed: do_compile (log file is located at /home/hcc/Desktop/legato_15-10/build_bin/tmp/work/armv7a-vfp-neon-poky-linux-gnueabi/legato-af/git-r0/temp/log.do_compile.40803)
ERROR: Logfile of failure stored in: /home/hcc/Desktop/legato_15-10/build_bin/tmp/work/armv7a-vfp-neon-poky-linux-gnueabi/legato-af/git-r0/temp/log.do_compile.40803
Log data follows:
| DEBUG: Executing shell function do_compile
| About to build for targets ar7 ar86 wp85
| Compiling legato-af for ar7
| /home/hcc/Desktop/legato_15-10/build_bin/tmp/work/armv7a-vfp-neon-poky-linux-gnueabi/legato-af/git-r0/temp/run.do_compile.40803: 134: /home/hcc/Desktop/legato_15-10/build_bin/tmp/work/armv7a-vfp-neon-poky-linux-gnueabi/legato-af/git-r0/temp/run.do_compile.40803: Bad substitution
| WARNING: exit code 2 from a shell command.
| ERROR: Function failed: do_compile (log file is located at /home/hcc/Desktop/legato_15-10/build_bin/tmp/work/armv7a-vfp-neon-poky-linux-gnueabi/legato-af/git-r0/temp/log.do_compile.40803)
ERROR: Task 1461 (/home/hcc/Desktop/legato_15-10/meta-swi/common/recipes-legato/legato-af/legato-af_git.bb, do_compile) failed with exit code '1’
NOTE: Tasks Summary: Attempted 1187 tasks of which 940 didn’t need to be rerun and 1 failed.
Waiting for 0 running tasks to finish:

Summary: 1 task failed:
/home/hcc/Desktop/legato_15-10/meta-swi/common/recipes-legato/legato-af/legato-af_git.bb, do_compile
Summary: There was 1 ERROR message shown, returning a non-zero exit code.
make: *** [image_bin] Error 1
[/i]


#2

I solved the issue.

The Legato docs say “Run echo 0 to check your shell." But this command returns the name of the current process. So the build process can open another shell which is not a bash. You need to execute [i]" sudo dpkg-reconfigure dash”[/i] on Ubuntu in all cases an answer the question with “NO”.

BR, Rene