le_atClient_Start(fd) crashes an app


#1

I have a WP7601 module, Running Legato 7.11. I’m trying to get the at commands to work, but right after the open, when I call le_atClient_Start(fd), the avcDaemon starts complaining with lots of LE_NOT_FOUND, failed to open /avc/fw/updateState… etc And then the app crashes. The code I’m using is straight out of the test for 7.11 framework. If I run JUST that code, I can get a little further where it tries to call le_atClient_Stop() and it crashes there. Has anyone even got this to work on a WP7601?

Thanks,
Evets


#2

Hello,

What is the device name pointing to fd ?
can you share the sample code flow of your app ?

Thanks,
Pinkesh Shah


#3

Hi @pinkesh,
Like I said above, this code is straight out of the Test code for the atClient. See below:
//! [DeviceBinding]
//! [binding]
int fd = open("/dev/ttyAT", O_RDWR | O_NOCTTY | O_NONBLOCK);

LE_ASSERT(fd >= 0);

int newFd = dup(fd);

DevRef = le_atClient_Start(fd);  // << In my app, it crashes here.  Keep in mind that 

// my app has a lot of other bindings, whereas the test app, it only has le_atClient.
//! [binding]

// Try to stop the device
LE_ASSERT(le_atClient_Stop(DevRef) == LE_OK);  // <<- In the test app it crashes here.
LE_ASSERT(le_atClient_Stop(DevRef) == LE_FAULT);

#4

Has anyone run this on the WP7601 product? I’ve tried with the MangOH board (green) and our own product and I still get the same issue.


#5

Hi @EvetsMostel,
Yes, Even we see atClientTest App stops failing to open /avc/fw/updateState avcDaemon and avcDaemon complaining with lots of LE_NOT_FOUND using legato-17.11.0(Release 7.0.1) and also with legato-18.01.0 version(Release 8).

Please check with the legato-18.03.0 version(WP7xx Release 9 ), This issue has been resolved in legato-18.03.0 version.

Regards,
Muralidhara N.