Issues using GDB (devMode) with legato 16.10.3

Hi,

I have been trying to configure my app so I can debug it with GDB with the Native Debug plugin on VSCode. Do note that I am using the Legato 16.10.3 framework.
In my .cdef, I have the following:

cxxflags:
{
-std=c++14
-g -O0
}

ldflags:
{
-g
}

So far, I’m able to succesfully start the GDB server on the target and I can connect a GDB client with my host, but I’m unable to debug because I keep getting the following output:

(gdb) target remote localhost:2000
Remote debugging using localhost:2000
warning: Unable to find dynamic linker breakpoint function.
GDB will be unable to debug shared library initializers
and track explicitly loaded dynamic code.
Cannot access memory at address 0x0
0x413a8ac0 in ?? ()

I’m pretty sure I followed step by step the following guides, and even tried desperate attempts like setting the sysroot and setting solib-absolute-prefix, but I still get the same issue over and over again:
https://docs.legato.io/16_10_3/basicTargetDevMode.html
https://docs.legato.io/16_10_3/howToDebugGDB.html#howToDebugGDB_building

I know the problem is not on VSCode end because I get the exact same issue with my launch configuration or by running GDB manually.

Do you know if there might be information I’m missing or is there anything that you guys know that might help me? I found similar questions in the forum, but it seems they were left without specific solutions. Sorry for the repost in advance.

do you find problem in Developer studio debug mode which using GDB?