How to use core dump file

Everytime a process inside my sandbox application crashes legato stores files in /tmp/legato_logs of which one is a system log and the other is a core dump file. I am uncertain on how to use these core dump files in order to track why my process crashes.

I’ve build my application like this:
mkapp -d debug_path …

which exported debug symbols if I am not mistaking to the specified path.

I’ve got the core dump file at this location:
~/Desktop/SWLogs/core-App-prc-1561278983.core

So I run my gdb server like this:

/opt/swi/y22-ext/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-gdb _build_APP20/wp76xx/app/APP20/staging/read-only/bin/omk /home/user/Desktop/SWLogs/core-APP20-omk-1561278983.core

Where first is the gdb exe, next is the process exe and third is the core dump file.
This is the output:

...is truncated: expected core file size >= 3164450816, found: 42332.
[New LWP 2352]
[New LWP 2353]
[New LWP 2328]
[New LWP 2330]
[New LWP 2331]
[New LWP 2335]
[New LWP 2336]
[New LWP 2337]
[New LWP 2338]
[New LWP 2343]
[New LWP 2344]
[New LWP 2345]
[New LWP 2346]
[New LWP 2348]
[New LWP 2350]
[New LWP 2351]
[New LWP 2334]
[New LWP 2357]
[New LWP 2347]
Core was generated by `omk'.
Program terminated with signal SIGABRT, Aborted.
#0  0xb64486a4 in ?? ()
[Current thread is 1 (LWP 2352)]

I tried using frame list, which resulted in message: No symbol table is loaded. Use the “file” command.

So I tried loading symbol table with command bellow, which returned Success.
file /home/user/debug_path

but even after this frame list gives me an error

Note:
I am not developing my application trough developer studio so I can’t use the PostMortem debug.

Either you are out of memory (maybe your list is too big for your memory) or you are trying somewhere in the memory that you are not allowed to.

Thank you for your reply, the actual problem was that sandbox app was making a file and writing to it, when file went over some size app would crash. Strange thing to us was that we expected supervizor to stop the app and notify us of the reason why the app was stopped, because we had all kind of limits defined in the adef file.

Anyway the question here is how can we load core dump file into developer studio or how can we use it properly?