Data connect fails due to missing DNS

Hello, I have a WP7700 red and I’m Following the getting started tutorial. I reached the point where I’m supposed to run redSensorToCloud in order to connect to the Cloud. However, this didn’t seem to work so I tried “cm data connect” and I figured out that the device didn’t connect because of the missing DNS I checked again and Indeed in the info the two DNS fields are empty(N/A). So I am sure that the sim card I have doesn’t offer DNS. Any idea how can I proceed ?

How about editng the /etc/resolv.conf file?

Actually I Don’t seem to find this file Under etc…

I can see it in WP76 module.

root@swi-mdm9x28:~# cat /etc/resolv.conf
root@swi-mdm9x28:~# cm data
Index: 1
APN: hkcsl
PDP Type: IPV4V6
Connected: no
root@swi-mdm9x28:~# cm info
Device: WP7608
IMEI: 352913090100734
FSN: XG805285330204
Firmware Version: SWI9X07Y_02.16.02.00 000000 jenkins 2018/04/19 19:59:02
Bootloader Version: SWI9X07Y_02.16.02.00 000000 jenkins 2018/04/19 19:59:02
[ 511.647542] i2c-msm-v2 78b8000.i2c: NACK: slave not responding, ensure its powered: msgs(n:1 cur:0 tx) bc(rx:0 tx:2) mode:FIFO slv_addr:0x3a MSTR_STS:0x081343c8 OPER:0x00000090
MCU Version: 002.009
PRI Part Number (PN): 9907762
PRI Revision: 001.001
Carrier PRI Name: GENERIC
Carrier PRI Revision: 002.032_000
SKU: 1103788
Last Reset Cause: Power Down
Resets Count: Expected: 526 Unexpected: 9

How about “touch /etc/resolv.conf” and restart cm data connect?

As you’ve suggested @JordanZhao.
We do that during our production testing, else the modems can’t establish a data connection.

which bearer are you using ?
Can you give the response of the following AT commands ?

Hello so when I created the file I put the google dns ( and within. When I run cm data connect it says that it is connected but I Don’t see anything on the airvantage. Is there a way to see the traffic at the level of the device ?
@fdu here is what I get for these commands:


And the second command :
current operating mode : 0x06
supported operated modes:
LTE WB: 0x01
LTE M1: 0x02
LTE NB1: 0x04


Sorry @Maroua
I forgot these 2 commands:
The aim is to know the current activated beader: LTE-M1 or LTE-NB1


Thank you for your quick comment @fdu
I obtained:
+CREG: 2,3

Mhh your device seems to be rejected by the network.
Can you check your APN setting in +CGDCONT command ?

So the Following pdp context is the Following:
+CGDCONT: 1,“IP”,“APN”,“”,0,0,0,0
and the APN is correctly set.
What would make the device rejected by the network ?

Are you sure that APN is the APN related to your SIM card ?
Can you send me the response to “AT+CIMI” command please ?

yes I’m sure about the APN. As for the command it successfully returns the IMSI.

hi @Maroua,
as indicated by fdu, your device is rejected by the network.
usually it means there is a mismatch between the APN allowed by the network and SIM and the one set into the device ( ie at+cgdcont)
can you double check the following:

cm SIM info
cm radio info
cm data info
in order to check every settings .

Best Regards,