Creating a data session while debugging


#1

Hello,

I am running the modemDemo sample application on a WP710x, using Developer Studio to display debug messages. When I sent the TestDataConnectionV4 SMS command to the application, it answered that it had failed to connect to sierrawireless.com.

After a rapid investigation, I discovered that once the data session is opened, the rmnet0 device is created. And routing table (as returned by ip route show) is:

which means that all connection requests targeting networks other than 10.193.224.0/24 will be routed over eth0, while they should be routed over rmnet0. To be sure, I modified the routing table:

(10.141.236.53 is the gateway address returned by the answer to the Netinfo SMS command).

And this time, the TestDataConnectionV4 worked perfectly.

Reading Modem Data Control section of Legato documentation, I didn’t find any way to specify the network interface to use, from an application. What would be the best way to do this?


#2

Going on with my tests, I happened to reboot the WP710x. Looking at the routing table again, I got:

which is correct… So what happened during my previous test? I’ll try to find out…


#3

Salut Pascal ! I hope you’re doing well after Dev Days :slight_smile:

So, your issue is solved, right?

.Thibault.


#4

Salut Thibault,

Yes, thanks. And, at last, I got some time to really start playing with Legato 8)

Well, solved for now, yes. But I’ll try to reproduce what happened, if possible. I’ll update this post accordingly.

Bonne après-midi,
P.


#5

Hello, I have similar problem, when I starting session using le_mdc_StartSession, I have no access to Internet because of wrong gateway.
route shows:

Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface ***.***.***.96 * 255.255.255.224 U 0 0 0 rmnet0 192.168.2.0 * 255.255.255.0 U 0 0 0 usb0

while le_mdc_GetIPv4GatewayAddress shows:
***.***.***.113

route add default gateway ***.***.***.113 solves this problem, but why the device picking wrong gateway after I call StartSession?
Is there any way to manually set the right gateway in my code?