15.10 Build Issues


#1

Hi,

I am constantly facing issues in building 15.10 framework on my system.

1st time I got some error

CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly. Missing variable is: CMAKE_C_COMPILER_ENV_VAR CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly. Missing variable is: CMAKE_C_COMPILER CMake Error: Could not find cmake module file: /dev/Legato/legato-af-master/build/ar7/CMakeFiles/2.8.12.2/CMakeCCompiler.cmake CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly. Missing variable is: CMAKE_CXX_COMPILER_ENV_VAR CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly. Missing variable is: CMAKE_CXX_COMPILER CMake Error: Could not find cmake module file: /dev/Legato/legato-af-master/build/ar7/CMakeFiles/2.8.12.2/CMakeCXXCompiler.cmake CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage -- Configuring incomplete, errors occurred! make: *** [build/ar7/Makefile] Error 1

Somehow this got sorted out and and second time I got error.

[code]CMake Error at platformServices/apps/fwupdate/CMakeLists.txt:17 (file):
file COPY cannot find
"/home/ubuntu/Legato/Karandeep/legato-af-master/components/fwupdate/platformAdaptor/pre-built/wp7/le_pa_fwupdate/libComponent_le_pa_fwupdate.so".

[/code]

I check with earlier versions of legato like 15.05 and found that .so files are missing in 15.10 because of which i was getting this error.
So I provided these files from an earlier version and a building process proceeded but yet again to encounter another error.

FAILED: /opt/swi/y16-ext/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-gcc -o /home/ubuntu/Legato/Karandeep/legato-af-master/build/wp7/platformServices/apps/audio/_build_audioService.wp7/staging/bin/audioDaemon /home/ubuntu/Legato/Karandeep/legato-af-master/build/wp7/platformServices/apps/audio/_build_audioService.wp7/obj/audioDaemon/_main.c.o -rdynamic -L/home/ubuntu/Legato/Karandeep/legato-af-master/build/wp7/platformServices/apps/audio/_build_audioService.wp7/staging/lib -Wl,--enable-new-dtags,-rpath="\$ORIGIN/../lib" "-L/home/ubuntu/Legato/Karandeep/legato-af-master/build/wp7/platformServices/apps/audio/_build_audioService.wp7/staging/lib" -lComponent_audio -lComponent_le_pa_audio "-L$LEGATO_BUILD/bin/lib" -llegato -lpthread -lrt -ldl -lm -lqmi_cci -lqmiservices /opt/swi/y16-ext/sysroots/armv7a-vfp-neon-poky-linux-gnueabi/usr/lib/libsierra_qcsi.a /opt/swi/y16-ext/sysroots/armv7a-vfp-neon-poky-linux-gnueabi/usr/lib/libsierra_sd_client.a arm-poky-linux-gnueabi-gcc: error: /opt/swi/y16-ext/sysroots/armv7a-vfp-neon-poky-linux-gnueabi/usr/lib/libsierra_sd_client.a: No such file or directory ninja: build stopped: subcommand failed. make[3]: *** [bin/apps/audioService.wp7] Error 1 make[3]: Leaving directory `/home/ubuntu/Legato/Karandeep/legato-af-master/build/wp7' make[2]: *** [platformServices/apps/audio/CMakeFiles/audioService.dir/all] Error 2 make[2]: Leaving directory `/home/ubuntu/Legato/Karandeep/legato-af-master/build/wp7' make[1]: *** [all] Error 2 make[1]: Leaving directory `/home/ubuntu/Legato/Karandeep/legato-af-master/build/wp7' make: *** [build_wp7] Error 2

Now can anybody tell me why i am constantly facing these errors ??
I have correctly installed all the packages, set the environment and extracted the toolchain.
I am trying to build this for WP7 which is constantly failing.

For WP85 it goes on pretty smoothly except in the end it issues a couple of warnings like

Target: wp85 Input: /home/ubuntu/Legato/Karandeep/legato-af-master/build/wp85/staging Output: /home/ubuntu/Legato/Karandeep/legato-af-master/build/wp85 Version: 15.10.1.Beta ubuntu-OptiPlex-7010 2016/01/19 13:54:51 wp85: Generating the framework image (yaffs2) wp85: Generating the framework cwe wp85: Generating the framework image (ubi) Warning: Unable to produce ubi image: fakeroot version >= 1.20.2 needed You can install fakeroot from ppa:cor-fr/fakeroot-backports $ sudo -E add-apt-repository ppa:cor-fr/fakeroot-backports && sudo apt-get update && sudo apt-get install fakeroot or You can build fakeroot using sources from http://http.debian.net/debian/pool/main/f/fakeroot/fakeroot_1.20.2.orig.tar.bz2 . Warning: Unable to provide valid CWE image for WP85

Any help regarding this issue will be appreciated !

Thanks


#2

Hi,

From the release note, WP7 target (for WP710x modules) is no more supported since Legato 15.10:

[quote][color=#FF0000]Module Support[/color]
Effective the Legato 15.10 Beta, the WP71 module is no longer supported.[/quote]

Regarding WP85, your warning message is because you are running a too old version of fakeroot.

If your Ubuntu version is an old one then it is not possible to update fakeroot to the expected version (>= 1.20.2) using the standard repository.
In this case, you have to follow the instructions reported by the warning message to do the update:

Warning: Unable to produce ubi image: fakeroot version >= 1.20.2 needed You can install fakeroot from ppa:cor-fr/fakeroot-backports $ sudo -E add-apt-repository ppa:cor-fr/fakeroot-backports && sudo apt-get update && sudo apt-get install fakeroot or You can build fakeroot using sources from http://http.debian.net/debian/pool/main/f/fakeroot/fakeroot_1.20.2.orig.tar.bz2 .
So, the easiest way to do the update is to run this command:

Jay