WP85 is using SIM dafult APN. How to Change?


#1

Hello

We have a SIM carad that depending on the APN we set up we can get a IP private address or a IP public address.

Using “Telefonica.es” we get the private IP adresss. Using “movistar.es” we get the public IP address. This SIM works OK with FXT009.

When we use this SIM in the new FX30 and we set up the APN with “movistar.es” we don´t get the public IP. We still have a private IP address. It´s a if WP85 is still getting the default APN of the SIM even we change it with “le_mdc_SetAPN” and “le_mdc_SetAuthentication” functions.

What we are doing wrong?

WP85 is connected and we can navigate in Internet bu IP address is private because is using the default APN.

Bellow the log:

Aug 9 06:47:13 | modemDaemon[598]/swiQmi T=main | swiQmi.c swiQmi_CheckResponse() 781 | Sending QMI_WDS_START_NETWORK_INTERFACE_REQ_V01 failed: rc=0 (), resp.result=1.[0x01], resp.error=26.[0x1a]
Aug 9 06:47:13 | modemDaemon[598]/le_pa T=main | pa_mdc_qmi.c StartSession() 1707 | Data connection failure reason not available
Aug 9 06:47:15 | modemDaemon[598]/swiQmi T=main | swiQmi.c swiQmi_CheckResponse() 781 | Sending QMI_WDS_START_NETWORK_INTERFACE_REQ_V01 failed: rc=0 (), resp.result=1.[0x01], resp.error=14.[0x0e]
Aug 9 06:47:15 | modemDaemon[598]/le_pa T=main | pa_mdc_qmi.c StartSession() 1690 | Data connection failure Call End provided 45, Code 1
Aug 9 06:47:15 | modemDaemon[598]/le_pa T=main | pa_mdc_qmi.c StartSession() 1701 | Data connection failure Verbose Call End provided Type 2, Verbose 204
Aug 9 06:47:15 | modemDaemon[598]/modemDaemon T=main | le_mdc.c le_mdc_StartSession() 919 | Get Connection failure 45, 1, 2, 204

We have this trace “Data connection failure reason not available”, “Get Connection failure 45, 1, 2, 204” shows error 45 (_mdc_DisconnectionReason_t de le_mdc_interface_h) LE_MDC_DISC_UNDEFINED = 45 ///< Undefined reason.

We also have tried (le_mdc_StartSessionAsync) but with the same result.


#2

Hi,

Did you try to set the apn with cm data command ?
What is the result of “cm data” command ?

If in case if you have not set apn using cm data command, Please try wih the below command to set the apn.

cm data apn “movistar.es

If you have set the apn using the above cm command and still it is not working, Please check the result of “cm data” command.

Regards,
Muralidhara N.


#3

Hi Muralidhara

Yes, we have tried with cm data apn but we still have the same result. We get a private IP address as if we still are using the default APN “telefonica.es” instead “movistar.es

When we ask for cm data info it looks apn is the rigth one but IP address still private

cm data info returns this:
Index: 1
APN: movistar.es
PDP Type: IPV4V6
Connected: yes
Auth type: ERROR
User name: movistar
Password: movistar


#4

Hello Isabel,

I also noticed an issue with APN, it may not strictly connected to your problem. Sometimes the FW changes the APN settings. In my case i am using right now a virtual operator’s SIM card and it changes to an old setting of the network which the mobile operator is on. I think it is coming from somewhere from a Qualcomm code inside, this old setting cannot be on the new SIM card. (Moreover on the SIM card there should be only a recommendation, the user should select the APN anyway) Why and when the firmware thinks it should change the APN i don’t know. It is not always happening after every startup.

What i do is at startup right after SIM ready i changing the APN settings if needed and i check it before every connection setup. The difference is that i use Data Connection API.
I noticed that your authentication type is ERROR (Auth type: ERROR)
Did you try to setup (LE_MDC_AUTH_PAP | LE_MDC_AUTH_CHAP) as in the example?
I am not sure that is not causing any problems, try only LE_MDC_AUTH_PAP or whatever you need.

tom


#5

Tom

Thank you. We have also test setting pap/chap authentication with same result

Isabel


#6

Hello Isabel,

It may be not a problem for us in the FX30 at all. The device is sometimes connected with USB to Windows and it can be that Windows 10 is overriding the APN settings automatically. We will look into that. Let us know if you find out more about your issue!

Cheers,
tom


#7

Hello Isabel,
Which is the firmware and legato framework you are using on FX30 module, Can you check this info using cm info and legato version command? Also can you check the same for FXT009 module?

Regards,
Muralidhara N.


#8

Hello Muralidhara

This is the firmware version of FX30 with cm info: Firmware: SWI9X15Y_07.11.22.00 r33729 CARMD-EV-FRMWR1 2017/01/11 18:04:06
Legato version : 16.10.1_eea67704afa1ebc0450d230baa84ac28_modified.

For FXT009 answer to ATI9:
“DWL”,“V08b13”,"",“Sierra Wireless”,55344,“111611 18:03”,“dda36757”,“00010000"
“FW”,“FW_SRC_747_8_F4_3.Q2687RDG”,“R7.47.4.201208311102.FXT009”,“Sierra Wireless”,2221264,“083112 11:02”,“6aa633a2”,“00020000"
“OAT”,””,"","",455028,“071414 16:05”,“d50c5898”,“00260000”
-“Developer Studio”,“2.3.2.201310241753”
-“Open AT Embedded Software Suite package”,“2.34.0.201009161320”
-“Open AT OS Package”,“6.34.0.201007281407”
-“Firmware Package”,“7.44.0.201008311212”
-“WIP Plug-in Package”,"5.40.0.201007290812"
“ROM”,"800000"
“RAM”,"200000"
“DWLNAME”,“FXT009”


#9

Hello Isabel,
From the information provided i see FXT009 has open AT framework?

Regards,
Muralidhara N.


#10

Hello Isabel,

Can you please try the below steps and check if it is working.

  1. Boot the FX30 module
  2. Turn OFF the radio (cm radio off)
  3. Set the APN (cm data apn “movistar.es”)
  4. Turn ON the radio (cm radio on)

Now you can try to connect and check if you are getting the public IP address.

Regards,
Muralidhara N.


#11

Hello

We have tried but we still don´t have public IP and we have the same error:
Aug 23 11:54:47 | modemDaemon[581]/swiQmi T=main | swiQmi.c swiQmi_CheckResponse() 781 | Sending QMI_WDS_START_NETWORK_INTERFACE_REQ_V01 failed: rc=0 (), resp.result=1.[0x01], resp.error=14.[0x0e]
Aug 23 11:54:47 | modemDaemon[581]/le_pa T=main | pa_mdc_qmi.c StartSession() 1690 | Data connection failure Call End provided 45, Code 1
Aug 23 11:54:47 | modemDaemon[581]/le_pa T=main | pa_mdc_qmi.c StartSession() 1701 | Data connection failure Verbose Call End provided Type 2, Verbose 204
Aug 23 11:54:50 | dcsDaemon[577]/dataConnectionService T=main | dcsServer.c SetModemGateway() 1561 | Could not save the default gateway
Aug 23 11:54:50 | modemDaemon[581]/swiQmi T=main | swiQmi.c swiQmi_CheckResponse() 781 | Sending QMI_WDS_GET_RUNTIME_SETTINGS_REQ_V01 failed: rc=0 (), resp.result=1.[0x01], resp.error=15.[0x0f]
Aug 23 11:54:50 | modemDaemon[581]/swiQmi T=main | swiQmi.c swiQmi_CheckResponse() 781 | Sending QMI_WDS_GET_RUNTIME_SETTINGS_REQ_V01 failed: rc=0 (), resp.result=1.[0x01], resp.error=15.[0x0f]
Aug 23 11:54:50 | modemDaemon[581]/swiQmi T=main | swiQmi.c swiQmi_CheckResponse() 781 | Sending QMI_WDS_GET_RUNTIME_SETTINGS_REQ_V01 failed: rc=0 (), resp.result=1.[0x01], resp.error=15.[0x0f]
Aug 23 11:54:50 | modemDaemon[581]/swiQmi T=main | swiQmi.c swiQmi_CheckResponse() 781 | Sending QMI_WDS_GET_RUNTIME_SETTINGS_REQ_V01 failed: rc=0 (), resp.result=1.[0x01], resp.error=15.[0x0f]
Aug 23 11:54:50 | modemDaemon[581]/swiQmi T=main | swiQmi.c swiQmi_CheckResponse() 781 | Sending QMI_WDS_GET_RUNTIME_SETTINGS_REQ_V01 failed: rc=0 (), resp.result=1.[0x01], resp.error=15.[0x0f]
Aug 23 11:54:50 | dcsDaemon[577]/dataConnectionService T=main | dcsServer.c AddNameserversToResolvConf() 1239 | Set DNS ‘80.58.61.250’ '80.58.61.254’
Aug 23 11:54:50 | modemDaemon[581]/swiQmi T=main | swiQmi.c swiQmi_CheckResponse() 781 | Sending QMI_WDS_GET_RUNTIME_SETTINGS_REQ_V01 failed: rc=0 (), resp.result=1.[0x01], resp.error=15.[0x0f]

These are the steps followed:
root@fx30s:~# cm radio off
root@fx30s:~# cm data apn movistar.es
root@fx30s:~# cm data auth pap MOVISTAR MOVISTAR
root@fx30s:~# cm data info
Index: 1
APN: movistar.es
PDP Type: IPV4V6
Connected: no
Auth type: PAP
User name: MOVISTAR
Password: MOVISTAR

root@fx30s:~# cm radio on
root@fx30s:~# cm data connect

We have trie with PAP and CHAP with the same result.

Thanks
Isabel


#12

Hello

it looks a problem with FX30S firmware (R13.1.3.001 using RS232, SWI 9X15Y 7.11.22. )

Using Mango Green WP85 with this firmware SWI 9X15Y 7.10.04. I have the public IP or private IP address depending the APN I have set up.

Linux swi-mdm9x15 3.14.29ltsi-13c67b16ff_922830eb31 #2 PREEMPT Fri Apr 15 02:38:16 PDT 2016 armv7l GNU/Linux
root@swi-mdm9x15:~# fwupdate query
Connecting to service …
Firmware Version: SWI9X15Y_07.10.04.00 r32393 CARMD-EV-FRMWR1 2016/06/01 20:30:40
Bootloader Version: SWI9X15Y_07.10.04.00 r32393 CARMD-EV-FRMWR1 2016/06/01 20:30:40
Linux Version: 3.14.29ltsi-c14b887744_39dcf2256d #2 PREEMPT Wed Jun 1 23:37:34 PDT 2016

Could you confirm is a firmware issue with the latest version of FX30S ?


#13

Hello

It looks a specif issue with the SIM card. Testing with another SIM card from other carriler FX30S is working fine and I get a public IP when I use the public APN and a prívate IP with the second APN without any issue.

I will take traces with the problematic SIM to debug what happen with that SIM.

Thanks