FX30_firmware_flash_issues


#1

Hello ,
I try to flash the firmware "mcu-rmfw-boot-yocto-legato_wp85.cwe "in FX30, but I find the following problem:
root@fx30s:~# fwupdate download mcu-rmfw-boot-yocto-legato_wp85.cwe
Connecting to service …
Connecting to service …
Download started …
Error in download
root@fx30s:~# packet_write_wait: Connection to 192.168.2.2 port 22: Broken pipe
Any ideas as to what’s going on¿
Thanks,


#2

Hi Aelkhabli,

Per other post, the issue maybe because Legato version different.

Please try and capture and share the complete response to confirm:

cm info
legato version
fwupdate query
logread -f &
fwupdate download ~/mcu-rmfw-boot-yocto-legato_wp85.cwe

Thx
L


#3

I had the same issue. It seems that you should use the modem firmware in the generic release 14 with Legato 16.10.3.
If you use a previous version of modem fw with Legato 16.10.3 fwupdate will not work for some reason.

Here is a combination that works:

root@device:~# cat /etc/legato/version
Build created at 2017-12-04_13:41:55

Yocto build version: SWI9X15Y_07.12.09.00

Build host: ip-10-0-2-114
Versions:

  • firmware: SWI9X15Y_07.12.09.00
  • poky: yocto-1.7.3-29-gc282df8
  • meta-openembedded: 70beecb
  • meta-swi: e65c639
  • meta-swi-extras: 796df54
  • linux-yocto-3.14/meta: 961ca71325
  • linux-yocto-3.14/machine: ab5094eade
  • meta-mangoh: b58ad3c

root@device:~# legato version
16.10.3_fa8853cdc75388874c6a2b90ab4a6789